PTP with L2 Forwarding switch (LS1028ARDB)

cancel
Showing results for 
Search instead for 
Did you mean: 

PTP with L2 Forwarding switch (LS1028ARDB)

Jump to solution
252 Views
ceroone
Contributor II

Hello,

I have two boards (i.MX8M Plus) connected to each other via a switch (LS1028ARDB).

I run the following script to configure the switch in L2 forwarding mode:

#!/bin/bash
INTERFACES = "swp0 swp1 swp2 swp3"
ip link set eno2 up
ip link add name br0 type bridge
for if in $INTERFACES;
do
    ip link set $if up
    ip link set dev $if master br0
done
ip link set br0 up

I then run ptp4l on both i.MX8M Plus boards. I emphasize that I don't run ptp4l on the LS1028ARDB because I would like to test to what extent adding a "classic" switch between two PTP clocks affects performance.

However, the synchronization doesn't work. I have the following display (on both i.MX8M Plus boards):

# ptp4l -i eth0 -m
ptp4l[xxxx.xxx]: selected /dev/ptp1 as PTP clock
ptp4l[xxxx.xxx]: port 1: INITIALIZING to LISTENING on INIT_COMPLETE
ptp4l[xxxx.xxx]: port 0: INITIALIZING to LISTENING on INIT_COMPLETE
ptp4l[xxxx.xxx]: port 1: LISTENING to MASTER on ANNOUNCE_RECEIPT_TIMEOUT_EXPIRES
ptp4l[xxxx.xxx]: selected local clock yyyyyy.yyyy.yyyyyy as best master
ptp4l[xxxx.xxx]: assuming the grand master role

Could you explain me why it doesn't work please?

PS1: I tried to perform this operation with a LS1021ATSN switch and it worked perfectly...
PS2: Ping also works fine

Labels (1)
0 Kudos
1 Solution
226 Views
yipingwang
NXP TechSupport
NXP TechSupport

ls1028 is working in the L2 bridge mode.  "ptp4l -i eth0" command is sending the ptp4l as UDP packages for synchronizing.

ls1021 traps the L2 ptp package to CPU port for ptp sync. But not for the L4 level package to CPU port. UDP package will forward directly.

ls1028 would trap both L2 ptp package and L4 ptp package to CPU port not forward to other ports. We suppose user to run the ptp4l in ls1028 as default since it own the capability of ptp syncing.

We suggest customer to run the ptp4l in the L2 mode with -2 parameter.

View solution in original post

0 Kudos
1 Reply
227 Views
yipingwang
NXP TechSupport
NXP TechSupport

ls1028 is working in the L2 bridge mode.  "ptp4l -i eth0" command is sending the ptp4l as UDP packages for synchronizing.

ls1021 traps the L2 ptp package to CPU port for ptp sync. But not for the L4 level package to CPU port. UDP package will forward directly.

ls1028 would trap both L2 ptp package and L4 ptp package to CPU port not forward to other ports. We suppose user to run the ptp4l in ls1028 as default since it own the capability of ptp syncing.

We suggest customer to run the ptp4l in the L2 mode with -2 parameter.

View solution in original post

0 Kudos