PTP on LS1028ARDB Felix switch

cancel
Showing results for 
Search instead for 
Did you mean: 

PTP on LS1028ARDB Felix switch

Jump to solution
272 Views
ceroone
Contributor II

Hello,

I have two LS1028ARDB, that I connected to each other using their SWP0 interface.
I then configured the "Single port mode" on both boards, to be able to use these interfaces independently (https://docs.nxp.com/bundle/GUID-C3A436DA-E944-4F73-9811-2335DEBD04D6/page/GUID-F27864B5-2195-4FC0-8...:
On Board A:
# ip a add 192.168.0.1/24 brd + dev swp0
# ip l set eno0 up
# ip l set swp0 up
On Board B:
# ip a add 192.168.0.2/24 brd + dev swp0
# ip l set eno0 up
# ip l set swp0 up

I then launch a PTP synchronization on both boards (using L2 Transport):
# ptp4l -i swp0 -2 -m
It works fine.

BUT, when I try to use UDP/IPv4, it doesn't work anymore:
# ptp4l -i swp0 -m
ptp4l[xxxx.xxx]: selected /dev/ptp1 as PTP clock
ptp4l[xxxx.xxx]: port 1: INITIALIZING to LISTENING on INIT_COMPLETE
ptp4l[xxxx.xxx]: port 0: INITIALIZING to LISTENING on INIT_COMPLETE
ptp4l[xxxx.xxx]: port 1: LISTENING to MASTER on ANNOUNCE_RECEIPT_TIMEOUT_EXPIRES
ptp4l[xxxx.xxx]: selected local clock yyyyyy.yyyy.yyyyyy as best master
ptp4l[xxxx.xxx]: assuming the grand master role

Is there a problem with the configuration of the interfaces ? I don't understand why it doesn't work with IP transport but it does with L2...

Thank you in advance for your help.

ceroone

Tags (4)
0 Kudos
1 Solution
220 Views
yipingwang
NXP TechSupport
NXP TechSupport
0 Kudos
2 Replies
221 Views
yipingwang
NXP TechSupport
NXP TechSupport
0 Kudos
271 Views
ceroone
Contributor II
0 Kudos