LX2160ARDB_REV2 SFP RX Issue

cancel
Showing results for 
Search instead for 
Did you mean: 

LX2160ARDB_REV2 SFP RX Issue

303 Views
tsungmin_wang
Contributor III

Hi NXP,

We use XFI to connect to SFP cage without PHY.

Currently, the system can detect the link status of SFP cage.

But, when I used pktgen to test. I found that the receive side could not get any packet.

I just connected the SFP port directly.

tmp.drawio.png

And make sure the status

tsungmin_wang_0-1643014884758.png

ifconfig after pktgen

 

eth8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::b8fe:9ff:fe4f:1c4e  prefixlen 64  scopeid 0x20<link>
        ether ba:fe:09:4f:1c:4e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1010  bytes 58796 (57.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth9: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::2044:c6ff:febd:e856  prefixlen 64  scopeid 0x20<link>
        ether 22:44:c6:bd:e8:56  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10  bytes 796 (796.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

RX packets of the receive side (eth9) is still 0, what may cause this issue?

 

0 Kudos
2 Replies

297 Views
ufedor
NXP TechSupport
NXP TechSupport

Please provide additional information:

1) U-Boot booting log

2) the processor connection schematics

3) frequencies of all applied SerDes reference clocks

0 Kudos

291 Views
tsungmin_wang
Contributor III

Hi,

Please check the attachments.

Including uboot log, serdes1-sch and clockgen-sch.

 

0 Kudos