LS1043A configure DPAA

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1043A configure DPAA

Jump to solution
1,118 Views
smruthi_ramesh
Contributor II

Hi, I am trying to configure DPAA on LS1043A. I have the Layerscape sdk kernel installed along with DPDK linux application. I am trying to run testpmd, but it gives me an error that no FMAN ports are available. I have an ethernet cable going from RGMII1 on the LS1043A RDB to my pc's ethernet port. I configured the address and am able to ping it as well. I want to know how to configure the FMAN to the RGMII1 port and how to run the testpmd application? Also the LSDK guide mentions ad a variable "othbootargs" during boot time for uboot. How is that done?

Tags (3)
1 Solution
966 Views
yipingwang
NXP TechSupport
NXP TechSupport

Rx:

# testpmd -c 0xe -n 1 -- -a --coremask=0xc --portmask=0x4 --forward-mode=rxonly

Tx:

# testpmd -c 0xe -n 1 -- -a --coremask=0xc --portmask=0x4 --forward-mode=txonly

View solution in original post

0 Kudos
4 Replies
966 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please boot up Linux system with USDPAA dtb file fsl-ls1043a-rdb-usdpaa.dtb.

Please configure bootargs similar as the following.

root=/dev/mmcblk0p4 rw rootdelay=10 console=ttyS0,115200 ramdisk_size=0x10000000 nokaslr bportals=s0 qportals=s0 default_hugepagesz=2MB hugepagesz=2MB hugepages=448 nmi_watchdog=0 rcupdate.rcu_cpu_stall_suppress=1

root@localhost:~# fmc -x
root@localhost:~# mkdir -p /mnt/hugepages
root@localhost:~# mount -t hugetlbfs none /mnt/hugepages
root@localhost:~# export DPAA_FMC_MODE=1
root@localhost:~# fmc -c /root/dpdkfiles/usdpaa_config_ls1043.xml -p /root/dpdkfiles/usdpaa_policy_hash_ipv4_1queue.xml -a
root@localhost:~# export DPAA_NUM_RX_QUEUES=1

Executing testpmd application:
• For TX only:
./bin/testpmd -c 0x3 -n 1 -- -i --nb-cores=1 --portmask=0x1 --nb-ports=1 --forward-mode=txonly

--disable-hw-vlan --port-topology=chained
• For RX only:
./bin/testpmd -c 0x3 -n 1 -- -i --nb-cores=1 --portmask=0x1 --nb-ports=1 --forward-mode=rxonly

--disable-hw-vlan --port-topology=chained

0 Kudos
966 Views
smruthi_ramesh
Contributor II

I am getting an error with using --port-topology=chained and it says invalid command

pastedImage_1.png

0 Kudos
967 Views
yipingwang
NXP TechSupport
NXP TechSupport

Rx:

# testpmd -c 0xe -n 1 -- -a --coremask=0xc --portmask=0x4 --forward-mode=rxonly

Tx:

# testpmd -c 0xe -n 1 -- -a --coremask=0xc --portmask=0x4 --forward-mode=txonly

View solution in original post

0 Kudos
966 Views
smruthi_ramesh
Contributor II

Thank you it worked. Is there any way to step through the code and see how it works on Codewarrior?

0 Kudos