Suspend Monitor Job Error

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Suspend Monitor Job Error

4,647 Views
giantmango
Contributor II

Hello,

Last time I encountered "SWD Discovery Failed" when debugging (thread here). Flash Magic Tool solved this problem. However, I'm in a new cycle in which I have to clear flash memory every time before I need to debug with MCUXpresso.

giantmango_0-1646383599607.png

 

Let me elaborate. It starts with clearing the flash memory of LPC55s2x-EVK with Flash Magic Tool. Then, debug with MCUXpresso. It works fine for the first time, but it always failed for the second time when I need to debug again. And it shows SWD discovery failed error message again. And I will need to clear flash memory with Flash Magic Tool again and repeat the process.

giantmango_0-1646384666876.png

Sometimes I get this error message saying "Debug port inaccessible after access at location 0x000064B4." Then, I'll have to reset the memory with Flash Magic Tool for it to work again. 

And if I'm not lucky, Flash Magic Tool won't work, either. This can be fixed with a PC restart

giantmango_1-1646384834130.png

 

 

Thanks.

Taylor

 

 

0 Kudos
8 Replies

4,565 Views
giantmango
Contributor II

Here's the detail about suspend monitor job error.

giantmango_0-1647846718930.png

 

0 Kudos

4,596 Views
Pavel_Hernandez
NXP TechSupport
NXP TechSupport

Hello,

Is it happening with other examples ?. I recommend update the firmware from the debugger of the board. You can check the section 3.2.2 from the user manual link below.

LPCXpresso55S69/LPCXpresso55S28 Development Board User Manual (nxp.com).

Regards,

Pavel_Hernandez

 

0 Kudos

4,570 Views
giantmango
Contributor II

Thanks for replying!

It does not happen when running the hello_world example.

The file does not download even when I clicked the download link.

 

Taylor

0 Kudos

4,555 Views
Pavel_Hernandez
NXP TechSupport
NXP TechSupport

Hello, 

Is this problem happens after the first debugging session? Whether this is the case, I suggest asure to kill the last debugging session. You can do this in MCUXpresso click in the red square, the image below.

Pavel_Hernandez_1-1647900347843.png

If you need more information, just let me know.

Best regards,

Pavel

0 Kudos

4,532 Views
giantmango
Contributor II

giantmango_0-1648031520339.png

I terminate the debug session by clicking this, but still got the same error and need to erase the flash again.

0 Kudos

4,522 Views
Pavel_Hernandez
NXP TechSupport
NXP TechSupport

Hello,

In previous messages, you stated that It does not happen when running the hello_world example. So this issue only happens at your code? Is there any configuration different from SDK examples?

I suggest update the firmware of the debugger, please refer to section 3.2.2, I attach the file you can't download.

Best regards,
Pavel

 

0 Kudos

4,517 Views
giantmango
Contributor II

Hello,

The attached file has no section 3.2.2. However, the problem is fixed. I deleted the example project and import a new SDK example. Then, I copy paste the code I had and it works. Thanks for helping. May I know what could be the cause to this problem and why this method helps?

 

Best,

Taylor

0 Kudos

4,508 Views
Pavel_Hernandez
NXP TechSupport
NXP TechSupport

Hello,

I'm sorry, it was in 3.2.1, but that is good news. 

Best regards,
Pavel

0 Kudos