LPC55S69 SDK example error

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC55S69 SDK example error

373 Views
Contributor III

Hi,

 

I use the IDE MCUXpresso IDE V11 and SDK 2.6 on the LPCXpresso55S69 board.

 

Wanting to build the project: lpcxpresso55s69_multicore_manager_cm33_core0 along with the associated project lpcxpresso55s69_multicore_manager_cm33_core1 get the following errors provided by linker:

 

"No slave code for _core_m33slave" and

"undefined symbol` __vectors_start___core_m33slave' referenced in expression "

 

This error also occurs with other projects in SDK 2.6 that use dual core.

 

Regards,
Neculai

 

 

Invoking: MCU Linker
arm-none-eabi-gcc -nostdlib -L"C:\Users\Culi\Documents\MCUXpressoIDE_11.0.0_2516\workspace\lpcxpresso55s69_multicore_manager_cm33_core0\libs" -Xlinker -Map="lpcxpresso55s69_multicore_manager_cm33_core0.map" -Xlinker --gc-sections -Xlinker -print-memory-usage -Xlinker --sort-section=alignment -Xlinker --cref -mcpu=cortex-m33 -mfpu=fpv5-sp-d16 -mfloat-abi=hard -mthumb -T lpcxpresso55s69_multicore_manager_cm33_core0_Debug.ld -o "lpcxpresso55s69_multicore_manager_cm33_core0.axf" ./utilities/fsl_assert.o ./utilities/fsl_debug_console.o ./utilities/fsl_str.o ./startup/boot_multicore_slave.o ./startup/startup_lpc55s69_cm33_core0.o ./source/mcmgr_core0.o ./source/semihost_hardfault.o ./mcmgr/mcmgr.o ./mcmgr/mcmgr_internal_core_api_lpc55s69.o ./drivers/fsl_clock.o ./drivers/fsl_common.o ./drivers/fsl_flexcomm.o ./drivers/fsl_gpio.o ./drivers/fsl_power.o ./drivers/fsl_reset.o ./drivers/fsl_usart.o ./device/system_LPC55S69_cm33_core0.o ./component/uart/usart_adapter.o ./component/serial_manager/serial_manager.o ./component/serial_manager/serial_port_uart.o ./component/lists/generic_list.o ./board/board.o ./board/clock_config.o ./board/pin_mux.o -lpower_hardabi
c:/nxp/mcuxpressoide_11.0.0_2516/ide/plugins/com.nxp.mcuxpresso.tools.win32_11.0.0.201905131304/tools/bin/../lib/gcc/arm-none-eabi/8.2.1/../../../../arm-none-eabi/bin/ld.exe: No slave code for _core_m33slave
c:/nxp/mcuxpressoide_11.0.0_2516/ide/plugins/com.nxp.mcuxpresso.tools.win32_11.0.0.201905131304/tools/bin/../lib/gcc/arm-none-eabi/8.2.1/../../../../arm-none-eabi/bin/ld.exe:lpcxpresso55s69_multicore_manager_cm33_core0_Debug.ld:123: undefined symbol `__vectors_start___core_m33slave' referenced in expression
collect2.exe: error: ld returned 1 exit status
make: *** [makefile:41: lpcxpresso55s69_multicore_manager_cm33_core0.axf] Error 1
"make -r -j4 all" terminated with exit code 2. Build might be incomplete.

0 Kudos
4 Replies

13 Views
NXP Employee
NXP Employee

The following article is recommend reading for LPC55xx multicore usage with MCUXpresso IDE:

Regards,

MCUXpresso IDE Support

0 Kudos

13 Views
Contributor III

Hi,

I have already read the "LPC55xx Multicore Applications with MCUXpresso IDE" document.

Link error refers to all the multicore examples found in SDK 2.6

Please help me correct this error!

Neculai

0 Kudos

13 Views
NXP TechSupport
NXP TechSupport

Hello Neculai Agavriloaie,

Could you please take a video or screenshot to your your steps.

I test on my side, it can work well.

BR

Alice

0 Kudos

13 Views
NXP TechSupport
NXP TechSupport

Hello Neculai Agavriloaie,

 Please try to first build the Core0 project, then Core1.


Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos