Error in Debug Authentication for LPC55S69

cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Debug Authentication for LPC55S69

Jump to solution
343 Views
MasaTanaka
Contributor I

Hi, I am in trouble in Debug Authentication for LPCXpresso 55S69 and SPSDK 1.6.3.

I just want to use Debug Authentication without Secure Boot. So I follow the procedure written in AN13037. (I understand some descriptions are different from spsdk 1.6.3) But, when I execute 'nxpdebugmbox auth' command, it causes error with flollowing messages.

INFO:spsdk.apps.nxpdebugmbox:Starting Debug Authentication
# Interface Id Description
----------------------------------------------------------------------------
0 PyOCD PRA1AQJR NXP Semiconductors LPC-LINK2 CMSIS-DAP V5.224
INFO:pyocd.coresight.dap:DP IDR = 0x6ba02477 (v2 rev6)
INFO:pyocd.coresight.ap:AP#2 IDR = 0x002a0000 (AP var0 rev0)
INFO:spsdk.debuggers.debug_probe_pyocd:PyOCD connected via LPC-LINK2 CMSIS-DAP V5.224 probe.
WARNING:spsdk.debuggers.debug_probe_pyocd:The memory interface not found - probably locked device
INFO:pyocd.coresight.dap:DP IDR = 0x6ba02477 (v2 rev6)
INFO:pyocd.coresight.ap:AP#2 IDR = 0x002a0000 (AP var0 rev0)
INFO:spsdk.debuggers.debug_probe_pyocd:PyOCD connected via LPC-LINK2 CMSIS-DAP V5.224 probe.
WARNING:spsdk.debuggers.debug_probe_pyocd:The memory interface not found - probably locked device
INFO:spsdk.apps.nxpdebugmbox:Debug Authentication ends without AHB access.

When I modify CMPA configuration and set CC_SOCU_PIN/DFLT of DBGEN&SPIDEN to 'Always Enable', authentication is done without error. (But it is meaningless setting.)

Does anyone have an idea what causes this error?

0 Kudos
1 Solution
327 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello,

Some days ago, our other customer had same issue, there are several outcomes from this work from my colleague, you can first check it:

1 Several AN13037  commands can be updated to match with the latest version of the SPSDK,

2 The AN13037 config file  (config.yml) could be updated to match the requirements of the nxpdebugmbox gendc  command. See email send  to author (AN13037 Debug authentication config file.zip)

3 We successfully tested Debug authentication on LPC55s69 and LPC55s06 using the latest version of SPSDK 1.6.3. 

4 When attempting to start a new debug session,  after issuing debug authentication successfully, 

Alice_Yang_0-1656314368021.png

 

If you are using  LPC-Link2 CMSIS FW and MCUXpresso IDE, the debug session may not start.

Current recommendation is to use  LPC-Link2 J-Link firmware.  MCU-LINK (r0FF) CMSIS-DAP V2.250 probe, was also able to start a debug session correctly, or more with reliability than LPC-Link2 CMSIS

 

5. A word document with detailed configuration steps is attached.

6 Configuration files for LPC55s69  artifacts is also attached.

 

View solution in original post

0 Kudos
3 Replies
328 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello,

Some days ago, our other customer had same issue, there are several outcomes from this work from my colleague, you can first check it:

1 Several AN13037  commands can be updated to match with the latest version of the SPSDK,

2 The AN13037 config file  (config.yml) could be updated to match the requirements of the nxpdebugmbox gendc  command. See email send  to author (AN13037 Debug authentication config file.zip)

3 We successfully tested Debug authentication on LPC55s69 and LPC55s06 using the latest version of SPSDK 1.6.3. 

4 When attempting to start a new debug session,  after issuing debug authentication successfully, 

Alice_Yang_0-1656314368021.png

 

If you are using  LPC-Link2 CMSIS FW and MCUXpresso IDE, the debug session may not start.

Current recommendation is to use  LPC-Link2 J-Link firmware.  MCU-LINK (r0FF) CMSIS-DAP V2.250 probe, was also able to start a debug session correctly, or more with reliability than LPC-Link2 CMSIS

 

5. A word document with detailed configuration steps is attached.

6 Configuration files for LPC55s69  artifacts is also attached.

 

0 Kudos
314 Views
MasaTanaka
Contributor I

Hi Alice,

Thank you for your informarion. That is greatly helpful.

I succeed to complete authentication with your sample data. I found I made a mistake on handling CFPA version number.

As a result, MCUXpresso IDE can found a brobe of LPC-LINK2 on LPCXpresso.

However, I still have aproblem at GDB connection. I will try to use J-link firmware for LPCXpresso. And I will report the result.

Thanks, 

0 Kudos
307 Views
MasaTanaka
Contributor I

I succeed to work with Debug Authentication by using J-Link on-board firmware on LPCXpresso 55S69.

In conclusion,

Alice's attachment documents and sample data works collectly with spsdk 1.6.3. And it is neccesary to replace the on-board probe firmware from CMSIS to J-Link to use Debug Authentication.

Thanks a lot!

 

0 Kudos