Latest UART Driver for Kinetis K60

cancel
Showing results for 
Search instead for 
Did you mean: 

Latest UART Driver for Kinetis K60

221 Views
Contributor I

Hello,

Where can I get the latest version (2.1.5) of UART driver for Kinetis K60?

With MCUXpresso (MCUXpresso IDE v11.0.0 as well as the previous version) and Kinetis SDK (Release Name: MCUXpresso Software Development Kit (SDK) Release Version: 2.2.0)

I get a warning during code generation for UART in MCUXpresso: "Unsupported version of UART driver in the toolchain/IDE. Required 2.1.5/actual: 2.1.4."

It seems the SDK has version 2.1.4. So, where can I get version 2.1.5?

Thanks,

Satish

0 Kudos
5 Replies

11 Views
NXP TechSupport
NXP TechSupport

Hello Satish,

I have tried replicating the same warning you are getting, but I've not achieved this. I am using MCUXpresso v11.0.0 and the SDK 2.2.0.

Are you using an example provided in the SDK? If not can you tell me the steps you took in order to come to this message?

Best Regards,

Sabina

0 Kudos

11 Views
Contributor I

Hello Sabina,

Following are the steps to recreate the warning message:

- Bring up MCUXpresso v11. I had dragged the latest SDK zip file into the MCUXpresso previously.
- Create a new project.
- Select MCU as K6x --> MK60DN256xxx10.
- Select SDK Debug Console as Semihost.
- Select All Drivers (just to simplify)
- Select Redirect printf/scanf to ITM
- Link application to RAM
- In Pins Config Tool, configure Pin 1 as UART1_TX and Pin 2 as UART_RX.
- In Problems window, a warning "Peripheral UART1 is not initialized" shows up.
- Right click on the message as select "Initialize UART peripheral". Window pops up showing UART component as required SDK component as "platfom.drivers.uart[2.1.5]". Looks like it is expecting 2.1.5 version.
Select OK.
- Now, another warning pops up in Problems window, "Unsupported version of UART driver in the toolchain/IDE. Required 2.1.5/actual: 2.1.4"

Inside the SDK, I do see uart revision as 2.1.4 in the manifest.xml file.

Regards,

Satish

0 Kudos

11 Views
NXP TechSupport
NXP TechSupport

Hi Satish,

   Thank you for providing the details, I was now able to reproduce the same warnings and consequently errors when building the project. I believe this is a bug concerning the config tools. I have reported this and will get back to you as soon as I get information on how to fix this.

   In the meantime can you try  this to see if this solves the issue for now. I was able to remove any errors when building the same project by doing the following. When you right click the warning to initialize the UART module, I unchecked the box that states "Show only the latest component versions". This now showed two options I click the earlier version of the UART 2.1.4, pressed ok. Now I have no errors or warning and when I built the project I also did not get any further errors. 

pastedImage_1.png

Thank you for your patience,

Sabina

0 Kudos

11 Views
Contributor III

Hi Sabirna

I attempted this right click of the warning, but I cannot get my system to open the window that you indicate.  Can you provide any further detailed instructions?

Thanks

Terry

0 Kudos

11 Views
Contributor III

I created a new workspace and things started to work.

Thanks

0 Kudos