K64F Freedom Development Board Won't Debug Examples

cancel
Showing results for 
Search instead for 
Did you mean: 

K64F Freedom Development Board Won't Debug Examples

245 Views
stephen_j_lower
Contributor I

Hi, everyone. I'm trying to get started with the NXP K64F Freedom board and I just started going through the examples on the "Getting Started" page listed here

The examples compile, but the debug feature works only very rarely. It will work at first, then when I try to debug again I get one of a few errors including:

1. 17^error,msg="Remote communication error. Target Disconnected: Success."

2. Error in final launch sequence

as shown in the attached images. 

17_Error.png

Error In final launch sequence.png

Failed to Connect.png

I've had some luck closing MCUXpress and disconnecting the development board, then reopening MCUXpress and reconnecting the dev board, but that only works occasionally. 

Please let me know if anything comes to mind.

Other information: I ordered this board last spring and I some other threads have mentioned updating firmware, so I'm going to look into that and I'll describe how I solved my problem, if I figure it out. 

0 Kudos
2 Replies

122 Views
BlackNight
NXP Employee
NXP Employee

Hi Stephen,

I had something similar a while back with a bad USB cable. So it might be worthwile to exchange it.

The other thing you already mentioned: I recommend to use a different debug firmware which is much faster than the CMSIS-DAP one. You can choose from P&E or use the SEGGER J-Link one (Segger J-Link OpenSDA Firmware with Virtual MSD | MCU on Eclipse ). Or use an external probe if you have one at hand (Debugging the FRDM-K64F with P&E Multilink | MCU on Eclipse ), as this is anyway something to have. If costs is a concern: there is the $20 LPC-Link2 (see LPC-Link2 Debug Probe | MCU on Eclipse ) or you can use (as a  the $6 LPC8345-BRK board (not intended for that purpose, but works very well: Tutorial: Transforming the NXP LPC845-BRK into a CMSIS-DAP Debug Probe | MCU on Eclipse )).

I hope this helps,

Erich

122 Views
williamfish
Contributor I

I have the same problem, after performing the above actions twice the issue persisted.

After leaving the FRDM board unplugged for half and hour and rebooting my PC then repeating it finally worked.

It has been very frustrating, hopefully won't reoccur.

Billy..

0 Kudos