External crystal TRK-KEA128 Demo Board

cancel
Showing results for 
Search instead for 
Did you mean: 

External crystal TRK-KEA128 Demo Board

Jump to solution
723 Views
sebastianprenge
Contributor II

Hello Community,

we have a TRK-KEA128 demo board with a PKEAZ128MLK chip. The board has a external crystal (Y2) which is conntected to PIN 13 (EXTAL) and 14 (XTAL). The cyrstal is not in the documentation but physical on the board. Unfortunately the crystal is not working if ICS mode FEE is selected. My project is a minimal Processor Expert Kinetis Dev Studio sample with CPU Bean, 250ms Timer Bean and LED Bean. The LED is toggeled with the timer event. The project is doing fine if ICS mode is FEI.

Any ideas?

Cheers

Seb

Labels (1)
0 Kudos
1 Solution
309 Views
sebastianprenge
Contributor II

Hello jeremyzhou,

your example is not working... You have to initialize the OSC_CR register with 0xB6 and not 0xA6...

But I wanted to have a processor expert projekt. Unfortunately there is a processor expert bug in the CPU_Init.c in Kinetis Sudio 1.1 and CW MCU (Eclipse). The OSC_CR register is not initialized in CPU_Init.c line 118 you have to add CPU_OSC_CR_CONFIG_0. The bug is fixed in Kinetis Studio 2 without notice...

Cheers

Sebastian

View solution in original post

0 Kudos
4 Replies
309 Views
ChrisN
Contributor II

I also got the new board rev.D with the Y2 crystal and here, too, it doesn't work. The symptom is that after starting the debugger it just hangs. I also tried to detect any clock directly at the crystal, but there is nothing going on. Did you make any progress on this?

0 Kudos
309 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Sebastian,

I've attached a demo which runs in FBE mode on TRK-KEA128 REV C, as I didn't have the TRK-KEA128 REV D on hand.

Please refer to it for details.
Have a great day,
Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
310 Views
sebastianprenge
Contributor II

Hello jeremyzhou,

your example is not working... You have to initialize the OSC_CR register with 0xB6 and not 0xA6...

But I wanted to have a processor expert projekt. Unfortunately there is a processor expert bug in the CPU_Init.c in Kinetis Sudio 1.1 and CW MCU (Eclipse). The OSC_CR register is not initialized in CPU_Init.c line 118 you have to add CPU_OSC_CR_CONFIG_0. The bug is fixed in Kinetis Studio 2 without notice...

Cheers

Sebastian

0 Kudos
309 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Sebastian,

I was wondering if you can show the the location of Y2, as I've not found the Y2 you mentioned in the TRK-KEA128 board until now.

I'd like to suggest that you can upload your project, then I can run it with the TRK-KEA128 board.

I'm looking forward to your reply.
Have a great day,

Ping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos