cannot set UART at 115200 Processor Expert and KE02

cancel
Showing results for 
Search instead for 
Did you mean: 

cannot set UART at 115200 Processor Expert and KE02

Jump to solution
362 Views
Contributor V

Hello,

I'm trying to set the UART at 115200 bps using the Asynchronous serial communication PE component with no success. Here's the available list shown by the Component inspector (max 56000 bps)

pe-uart.png

The KE02Z device is running at max (I think) ICS clock of 32MHz and the bus clock at 16MHz.

I need to set the UART at 115200 bps. How can I do it?

regards,

gaston

1 Solution
46 Views
NXP Employee
NXP Employee

Hi Gaston,

in the document https://www.nxp.com/docs/en/fact-sheet/KINETISKE0XFS.pdf I found:

Internal clock source (ICS): Internal FLL with internal or external reference, precision trimming of internal reference allowing 1% deviation across temperature range of 0 °C to 70 °C and 1.5% deviation across temperature range of –40 °C to +105 °C, up to 48 MHz

Other useful application notre: https://community.nxp.com/docs/DOC-95356

Regards

Marek

Regards,
Marek

View solution in original post

0 Kudos
6 Replies
47 Views
NXP Employee
NXP Employee

Hi Gaston,

in the document https://www.nxp.com/docs/en/fact-sheet/KINETISKE0XFS.pdf I found:

Internal clock source (ICS): Internal FLL with internal or external reference, precision trimming of internal reference allowing 1% deviation across temperature range of 0 °C to 70 °C and 1.5% deviation across temperature range of –40 °C to +105 °C, up to 48 MHz

Other useful application notre: https://community.nxp.com/docs/DOC-95356

Regards

Marek

Regards,
Marek

View solution in original post

0 Kudos
46 Views
Contributor V

Thank you Marek, excellent support.

gaston

46 Views
NXP Employee
NXP Employee

Hi Gaston,

here is how you can easily review possible timing for the peripheral:

- open timing dialog

- type required value, e.g. 115200 into table on the left side

- if not possible to set desired value, increase "Allowed error" below (to 10-90%)

- after timing is set, open "Clock path" tab on the right side

- review clock propagation from the source to the peripheral 

  and check what closest value is selected

Hope this helps

Regards

Marek

Regards,
Marek
0 Kudos
46 Views
Contributor V

Hi Marek,

Yes, I did as you suggested but I'm not able to change the clock path. It is fixed as shown with the UART settings at 111.111 bps (above of recommended 1.5% precision)

Screenshot from 2018-02-21 09-49-03.png

Any hint to set the rate below 1.5% of the allowed error?

regards,

gaston

0 Kudos
46 Views
NXP Employee
NXP Employee

Hi Gaston,

can you trim internal oscilator (32.768kHz)?

Regards

Marek

Regards,
Marek
0 Kudos
46 Views
Contributor V

Marek, great tip! I've managed to trim the RC oscillator to 32.2KHz in order to get the desired UART data rate

Screenshot from 2018-02-21 16-59-59.png

It's okay but..., what about the drift of IRC (due to temperature variations, settings accuracy,...)? I'm not able to find this information in the KE02 Sub-Family Data Sheet. Could you help me with this last question?

regards,
gaston

0 Kudos