KSDK Library mode

cancel
Showing results for 
Search instead for 
Did you mean: 

KSDK Library mode

Jump to solution
662 Views
oaf
Contributor IV

I'm using KDS-2.0.0 and KSDK-1.1.0 and have some troubles. I want to link KSDK from libraries and not include the sw into my project.

This could be done from Project->Properties->Processor Expert -> Kinetis SDK Specific

 

18636_18636.pngpastedImage_1.png

 

In KDS-1.1 I could select

    platform_lib AND hal_lib AND startup_lib

Now I could select

     (platform_lib OR hal_lib) AND startup_lib

There is no HELP available that I've found so I have selected platform_lib AND startup_lib.

 

Is there any explanation regarding this choice?

When making my project now I got a message telling about an unneeded file:

 

18637_18637.pngpastedImage_2.png

 

But when this file is removed my project will NOT link:

 

18638_18638.pngpastedImage_3.png

 

When investigating this, I've found that SystemInit() is located in the file which was presumed no longer needed.

Is this a bug in KDS? Or is there some additional flag that I need to set?

Labels (1)
Tags (2)
0 Kudos
1 Solution
236 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Ole Asbjorn Fadum:

When those options are checked, Processor Expert do not handle the corresponding KSDK source files. In this case if you check the "startup_lib" option, as the message indicates the system_MK64F12.c file is removed and you need to include the compiled startup library. For this you have to:

1) Import the startup library project (File -> Import -> General -> Existing Projects into Workspace). The project is located in: C:\Freescale\KSDK_1.1.0\lib\ksdk_startup_lib\kds\K64F12.

2) Build the project. Then a file with name "libksdk_startup.a" should be generated.

3) Finally include this file in the linker options of your project (Properties -> C/C++ Build -> Settings -> Cross ARM C++ Linker -> Libraries):

Startup_library.png

Then your project should build with no errors.


Regards!,
Jorge Gonzalez

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
237 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Ole Asbjorn Fadum:

When those options are checked, Processor Expert do not handle the corresponding KSDK source files. In this case if you check the "startup_lib" option, as the message indicates the system_MK64F12.c file is removed and you need to include the compiled startup library. For this you have to:

1) Import the startup library project (File -> Import -> General -> Existing Projects into Workspace). The project is located in: C:\Freescale\KSDK_1.1.0\lib\ksdk_startup_lib\kds\K64F12.

2) Build the project. Then a file with name "libksdk_startup.a" should be generated.

3) Finally include this file in the linker options of your project (Properties -> C/C++ Build -> Settings -> Cross ARM C++ Linker -> Libraries):

Startup_library.png

Then your project should build with no errors.


Regards!,
Jorge Gonzalez

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
236 Views
oaf
Contributor IV

Yes, seems that I've mixed up the library specification to the linker,

thanks.

0 Kudos