KDS debugger multilink and K10

cancel
Showing results for 
Search instead for 
Did you mean: 

KDS debugger multilink and K10

Jump to solution
1,216 Views
kappa74
Contributor IV

Good morning,

I use KDS1.1.1 connected with a board with micro MK10DN512VLL10 and MQX4.1.1.

I'd like to migrate from CW10.4 to KDS1.1.1.

I can compiling the software but I can't use the debugger PE Multilink and I can't so neither to debug neither to flash the micro.

When I start the debug, I'll get:

****************

P&E GDB Server, Version 5.13.02.00

Copyright 2014, P&E Microcomputer Systems Inc, All rights reserved

 

Loading library C:\Freescale\KDS_1.1.1\eclipse\plugins\com.pemicro.debug.gdbjtag.pne_1.1.6.201409261701\win32\gdi\unit_ngs_arm_internal.dll ... Done.

 

Command line arguments: -device=K10DN512 -startserver -singlesession -serverport=7224 -interface=USBMULTILINK -speed=5000 -port=USB1 -USE_CYCLONEPRO_RELAYS=0 -FORCE_MASS_ERASE=0

Device selected is k10dn512

User Specified Hardware Selection : Interface=USBMULTILINK and Port=USB1

Connecting to target.

P&E Interface detected - Flash Version 6.10

 

Can not enter background mode  .

 

 

 

Unable to initialize PEDebug.

 

PE-ERROR: Failed to Initialize Target

Server running on 127.0.0.1:7224

Connection from "127.0.0.1" via 127.0.0.1

PE-ERROR: Target is not connected

Disconnected from "127.0.0.1" via 127.0.0.1

Target Disconnected.

****************

 

The debugger with the same board is working under CW10.4 but it is not working under KDS.

 

Do you have any idea?

Labels (1)
0 Kudos
1 Solution
307 Views
ivadorazinova
NXP Employee
NXP Employee

Hi Mirko,

The checked "Use SWD reduced pin protocol for communications" means that you have not full JTAG connection. SWD means Single Wire Debug. Here you have more information about the Debug port interface.

Using the FRDM-K64F with CodeWarrior | MCU on Eclipse

Is it now clear for you?

Iva

View solution in original post

0 Kudos
6 Replies
307 Views
antonioconcio
NXP Employee
NXP Employee

Ciao Mirko,

HERE you can find a guide on how porting CW projects to KDS.

About your issue, You can see HERE how to setup debug configurations with recommended settings. If it still fails, could you try to reduce the ‘Debug Shift Freq (KHz)’ e.g. 2000?

Hope that helps,

Antonio

0 Kudos
307 Views
kappa74
Contributor IV

Good morning Antonio,

In the link where it is explained the porting from CW to KDS there are three attached documents in docx. I can't open them even if I have Word 2013: maybe because I have Windows 8?

Can you attached document in pdf?

However I'm able to building the project in KDS1.1.1 but the problem is that I'm not able to debug it.

I follow the procedure in the link HERE, but I don't solve the situation.

I tried with 'Debug Shift Freq (kHz)' set as 3000-2000-1000-500, but I don't solve the situation.

In the relative BSP project, when I compile, I'll get the warning "The PLL/FLL clock value is 0 - the clock is disabled (Clock frequency [MHz])" but when I compile it with CW10.4, I will not get this warning and everything is working.

Any suggestion? Is there any problem with K10 and PE debugger under KDS1.1.1?

Best Regards

Mirko

0 Kudos
307 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Mirko:

Can you show a screenshot of the debug configuration tabs?

In your first post you showed the "main" tab, but we need to see the "Debbuger" and "Startup" tabs also.

Regards!
Jorge Gonzalez

0 Kudos
307 Views
kappa74
Contributor IV

Hi Jorge,

After many attempts, the debugger starts to work with K10.

It started to work after unchecked the "Use SWD reduced pin protocol fo communications" (see picture), but I don't understand why.

Do you know why it started to work well after this setting?

Best Regards

Mirko

Deb1.jpg

308 Views
ivadorazinova
NXP Employee
NXP Employee

Hi Mirko,

The checked "Use SWD reduced pin protocol for communications" means that you have not full JTAG connection. SWD means Single Wire Debug. Here you have more information about the Debug port interface.

Using the FRDM-K64F with CodeWarrior | MCU on Eclipse

Is it now clear for you?

Iva

0 Kudos
307 Views
kappa74
Contributor IV

OK,

Thank you.

Mirko

0 Kudos