NXP Touch Tuning not Opening Properly in FreeMASTER

cancel
Showing results for 
Search instead for 
Did you mean: 

NXP Touch Tuning not Opening Properly in FreeMASTER

496 Views
xpress-embedo
Contributor III

Hello Everyone.

I am new to the NXP and I have to use NXP micro MKE15Z in a project for touch-related application.

I found one tool for Touch Tunning but it's not working with FreeMaster 2.5 and also with the latest 3.0.

Can anyone please help me in understanding how it will work?

 

FreeMASTER project is available under the following path of the SDK

SDK\MKE15Z256xxx7_SDK\middleware\touch\freemaster\NXPTouchKE15.pmp

When I open this file I get a lot of errors in running the javascript files.

Problem-1.PNG

And Finally after clicking on "Yes" multiple times it looks like this.

Problem-2.PNG

Please suggest, what I am doing wrong.

I have both FreeMaster 2.5 and FreeMASTER 3.0 installed on my laptop, but both are giving the same problem.

And yes my system meets the required requirement.

Can you please suggest, where should I debug to find out the problem?

I have previously created a ticket in the Kinetis Board, now moving to FreeMASTER board as suggested.

https://community.nxp.com/thread/528427 

Tags (1)
8 Replies

246 Views
MichalH
NXP Employee
NXP Employee

Hello, 

this seems like an issue with Internet Explorer compatibility. FreeMASTER uses IE component internally to render the HTML control page. All restrictions which limit IE functions also affect FreeMASTER. 

Please check the following:

  • Are you able to run the IE for general internet browsing?
  • Make sure you open the FreeMASTER project from local hard drive (not a network-attached shared drive)
  • Open menu Tools/Internet options and select the Advanced tab in the dialog. In the Security section, makes sure you have "Allow active content .... to run on My Computer".

     pastedImage_1.png

  • With FreeMASTER open, try to open the touch control page HTML in the standalone IE. Just to see if it throws the same error...  

Thank you,

Michal

0 Kudos

246 Views
xpress-embedo
Contributor III

Thanks, MichalH‌ for your quick response.

Yes, I am able to use Internet Explorer for internet access (I don't use Chrome in a normal scenario, but it works).

FreeMASTER project is also on my local hard drive.

I tried to enable the "Allow Active Content..." option, but unfortunately, I didn't this option.

No Advance Option.PNG

This is my office laptop running on Windows 10 (I have admin rights).

Is there some other way to fix it?

I tried to run the *.html file in Internet Explorer, and got this, even after clicking on Allow, multiple times, it just opens the page but nothing is working.

Error.PNG

0 Kudos

246 Views
MichalH
NXP Employee
NXP Employee

So, it indeed seems that the Internet Explorer is not allowed to display pages with JavaScript-based Active Content. Most probably, your employer has also disabled access to the Advanced IE properties. There are two ways how it is normally done - in Policy Settings or directly in the Registry. Both ways are described in this article.

I recommend you to discuss the limitations with your administrator and see how you could gain access the advanced IE settings to enable the Active Content. If the page still does not work after it, we will investigate further.

Thanks,

MIchal Hanak

246 Views
xpress-embedo
Contributor III

Hi MichalH

Thank you for your response. I checked the link you suggested and changed the registry value and now I have the advance option available in Internet Options, and after changing to allow active content, this is not working now also.

Advance Options.PNG

TouchConfig_NotWorking.PNG

And when running on Internet Explorer, it looks like running, but all button looks disabled.

InternetExplorer.PNG

Sorry for the delayed response, Can you please support now, what should I do?

0 Kudos

246 Views
MichalH
NXP Employee
NXP Employee

Hello,

can you run the Internet Explorer and go to menu Help/About? Show me the version information please. 

I have another question: when FreeMASTER is NOT running, and you open the touch HTML page in a standalone Internet Explorer - does the FreeMASTER start automatically or not? And does the IE show any yellow information bar at the top of the window?

Thank you for your cooperation,

Michal

0 Kudos

246 Views
xpress-embedo
Contributor III

Hi MichalH
Thank you for your response.

Regarding Internet Explorer Version, please see the below screenshot.

Internet Explorer Version.PNG

And regarding your other question, FreeMASTER doesn't open itself when I open the Touch HTML page in Internet Explorer.

And when I open the HTML file I get a yellow information bar, asking for Allowing the blocked Active X Content, by allowing Internet Explorer displays as shown below, but none of the buttons are working.

Allowed Block Content.PNG

I have another personal laptop, on which this is working fine, but I don't understand why it is not working on the office laptop.

I hope we will be able to find a solution to this. Thanks for your support.

0 Kudos

246 Views
MichalH
NXP Employee
NXP Employee

Hello, 

it seems the ActiveX scripting is also disabled somewhere else. Can you check the Internet Options - the Security tab? Select the Local Intranet and press Custom level... Then enable the items as in the picture below. Also do the same for Trusted sites zone.

pastedImage_1.png pastedImage_2.png

Thanks,

Michal

246 Views
xpress-embedo
Contributor III

Thanks, MichalH

Unfortunately, this setting is also disabled on my office laptop.
I will check with my IT team if this can be resolved at there end by doing some changes or not.

0 Kudos