Freemaster Chromium page not rendering

cancel
Showing results for 
Search instead for 
Did you mean: 

Freemaster Chromium page not rendering

Jump to solution
329 Views
Contributor II

Dear all,

I use Freemaster to controll a S12ZVL devkit, I created a control page (html, css, js) for this.

My page renders correctly first, but turns blank once I hit 'Go'. This issue doesn't occur when I use the Internet explorer loading option.

Any clues ?

Regards,

Matisse

Edit : It seems that the rendering issue is linked with the variable watch window, when no variables are watched, the chromium option is working.

0 Kudos
1 Solution
194 Views
NXP Employee
NXP Employee

Dear Matisse,

thanks for additional information and your cooperation to resolve the issue (outside of this community thread).

The fix will appear in the upcoming FreeMASTER 3.1 by end of October.

Regards,
Michal

View solution in original post

5 Replies
293 Views
Contributor II

Dear MichalH,

Thank you for your answer, When the variable watch grid is empty, I can render my chromium page.

I tried repositioning or hiding the watch bar but it does not solves the problem, when some variables are watched, the page remains blank.

It seems that the issue is linked to the sampling period of the variables, each time a variable is refreshed, the chromium page goes blank.

0 Kudos
259 Views
NXP Employee
NXP Employee

Dear Matisse,

very strange indeed. I cannot see any linkage between the watch view and the chromium engine. These two components are quite independent. Can you tell me more about the page being displayed in chromium?

  • Does it have any timer or other frequent event which could prevent its refreshing?
  • Can you simplify the page code down (remove as much code as possible) to see if it helps? 
  • Does the issue happen even with a bare minimalistic page without any JavaScript code?
  • Can you test your page in a standalone Chrome browser - does it work? Does the debugging console show any suspicious messages? (press F12) 

Thank you for your cooperation.
Michal

0 Kudos
246 Views
Contributor II

Dear MichalH

The issue occurs even with the chromium page example provided from Freemaster's folder.

Everything works with no errors on a standalone chrome page ( no messages from the console).

Regards,

Matisse

0 Kudos
195 Views
NXP Employee
NXP Employee

Dear Matisse,

thanks for additional information and your cooperation to resolve the issue (outside of this community thread).

The fix will appear in the upcoming FreeMASTER 3.1 by end of October.

Regards,
Michal

View solution in original post

300 Views
NXP Employee
NXP Employee

Dear Matisse,

thanks for the report. I have not seen this issue happening before. 

So do you confirm that when the Variable Watch grid is empty, the Chromium page does not render well? Can you please try to reposition the Watch bar (just drag & drop it) and move it to the left or right side of the main window? Does it help when you hide the Watch pane completely?

Thank you,
Michal

0 Kudos