Code Warrior Installation Problem (for Ubuntu 14.04)

cancel
Showing results for 
Search instead for 
Did you mean: 

Code Warrior Installation Problem (for Ubuntu 14.04)

Jump to solution
1,123 Views
Contributor II

Hi,

 

I tried to install CodeWarrior for QorIQ LS Series ARMv7 ISA Linux v10.0.7  (evaluation version)- Offline to Ubuntu 14.04 (LTS, x64).

However I Received a lot of errors during the installation of the dependencies. Please see below.

 

How can I install the CodeWarrior? 

 

 

I followed the instructions: I downloaded the file (CodeWarrior for QorIQ LS Series ARMv7 ISA Linux v10.0.7 - Offline.tar) from Freescale website, extracted the TAR file, opened the new terminal window in the disk1 directory and started   ./setuplinux command.

 

However I got the followed message:

The dependencies could not be automatically installed. Please try to manually install the following dependencies and then restart the installer:

libc6:i386

libgcc1:i386

gcc-4.6-base:i386

libstdc++5:i386

libstdc++6:i386

libgtk2.0-0:i386

 

I attempted to install the dependencies manually as it mentioned in the README file (paragraph 2.13 Ubuntu 13.10 /14.04):

 

# sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

# sudo apt-get update

# sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libgtk2.0-0:i386 libxpm4:i386 libusb-0.1-4:i386 libusb-1.0-0:i386 libuuid1:i386 libxcb1:i386 libnspr4:i386 libglib2.0-0:i386 libxdamage1:i386 libxtst6:i386 libssl0.9.8:i386

 

However I received the list of errors:

E: Package 'libc6:i386' has no installation candidate

E: Package 'libgcc1:i386' has no installation candidate

E: Unable to locate package gcc-4.6-base

E: Couldn't find any package by regex 'gcc-4.6-base'

E: Unable to locate package libstdc++5

E: Couldn't find any package by regex 'libstdc++5'

E: Package 'libstdc++6:i386' has no installation candidate

E: Package 'libgtk2.0-0:i386' has no installation candidate

E: Unable to locate package libxpm4

E: Unable to locate package libusb-0.1-4

E: Couldn't find any package by regex 'libusb-0.1-4'

E: Unable to locate package libusb-1.0-0

E: Couldn't find any package by regex 'libusb-1.0-0'

E: Package 'libuuid1:i386' has no installation candidate

E: Unable to locate package libxcb1

E: Package 'libnspr4:i386' has no installation candidate

E: Package 'libglib2.0-0:i386' has no installation candidate

E: Package 'libxdamage1:i386' has no installation candidate

E: Package 'libxtst6:i386' has no installation candidate

E: Unable to locate package libssl0.9.8

E: Couldn't find any package by regex 'libssl0.9.8'

 

Regards Victor

Labels (1)
0 Kudos
1 Solution
77 Views
NXP Employee
NXP Employee

Hello Victor Mazin,

I tried on my Ubuntu 14.04 64bit, it prints message that CodeWarrior dependency will not be automatically installed, after a while when I was checking the dependency the installation go on and success.

This seems to be related with source. Attached is my sources.list.

pastedImage_0.pngpastedImage_1.png

View solution in original post

0 Kudos
5 Replies
78 Views
NXP Employee
NXP Employee

Hello Victor Mazin,

I tried on my Ubuntu 14.04 64bit, it prints message that CodeWarrior dependency will not be automatically installed, after a while when I was checking the dependency the installation go on and success.

This seems to be related with source. Attached is my sources.list.

pastedImage_0.pngpastedImage_1.png

View solution in original post

0 Kudos
77 Views
NXP Employee
NXP Employee

Hi Victor,

Could you please provide also the log when run # sudo apt-get update

Adrian

0 Kudos
77 Views
Contributor II

Hi Adrian,

Thank you for the answer. 

Please see the log below.

Regards

Victor

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/Warrior/disk1$ sudo apt-get update

Ign http://dl.google.com stable InRelease

Hit http://dl.google.com stable Release.gpg                                   

Hit http://dl.google.com stable Release                                       

Ign http://extras.ubuntu.com trusty InRelease                                 

Ign http://old-releases.ubuntu.com trusty InRelease                           

Hit http://dl.google.com stable/main amd64 Packages                           

Hit http://extras.ubuntu.com trusty Release.gpg                               

Ign http://old-releases.ubuntu.com trusty-updates InRelease                   

Hit http://dl.google.com stable/main i386 Packages                            

Hit http://extras.ubuntu.com trusty Release                                   

Hit http://repos.codelite.org trusty InRelease                                

Ign http://old-releases.ubuntu.com trusty-backports InRelease                 

Ign http://old-releases.ubuntu.com trusty-security InRelease                  

Hit http://extras.ubuntu.com trusty/main Sources                              

Hit http://repos.codelite.org trusty/universe amd64 Packages                  

Ign http://old-releases.ubuntu.com trusty Release.gpg                         

Hit http://extras.ubuntu.com trusty/main amd64 Packages                       

Hit http://repos.codelite.org trusty/universe i386 Packages                   

Ign http://old-releases.ubuntu.com trusty-updates Release.gpg                 

Hit http://extras.ubuntu.com trusty/main i386 Packages                        

Ign http://old-releases.ubuntu.com trusty-backports Release.gpg               

Ign http://dl.google.com stable/main Translation-en_CA                        

Ign http://dl.google.com stable/main Translation-en                  

Ign http://old-releases.ubuntu.com trusty-security Release.gpg       

Ign http://old-releases.ubuntu.com trusty Release                    

Ign http://old-releases.ubuntu.com trusty-updates Release            

Ign http://old-releases.ubuntu.com trusty-backports Release          

Ign http://old-releases.ubuntu.com trusty-security Release           

Ign http://extras.ubuntu.com trusty/main Translation-en_CA           

Ign http://extras.ubuntu.com trusty/main Translation-en

Ign http://repos.codelite.org trusty/universe Translation-en_CA

Ign http://repos.codelite.org trusty/universe Translation-en

Err http://old-releases.ubuntu.com trusty/main Sources                        

  404  Not Found

Err http://old-releases.ubuntu.com trusty/restricted Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty/universe Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty/multiverse Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty/main amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/restricted amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/universe amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/multiverse amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/main i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/restricted i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/universe i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty/multiverse i386 Packages

  404  Not Found

Ign http://old-releases.ubuntu.com trusty/main Translation-en_CA

Ign http://old-releases.ubuntu.com trusty/main Translation-en

Ign http://old-releases.ubuntu.com trusty/multiverse Translation-en_CA

Ign http://old-releases.ubuntu.com trusty/multiverse Translation-en

Ign http://old-releases.ubuntu.com trusty/restricted Translation-en_CA

Ign http://old-releases.ubuntu.com trusty/restricted Translation-en

Ign http://old-releases.ubuntu.com trusty/universe Translation-en_CA

Ign http://old-releases.ubuntu.com trusty/universe Translation-en

Err http://old-releases.ubuntu.com trusty-updates/main Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/restricted Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/universe Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/multiverse Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/main amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/restricted amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/universe amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/multiverse amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/main i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/restricted i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/universe i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-updates/multiverse i386 Packages

  404  Not Found

Ign http://old-releases.ubuntu.com trusty-updates/main Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-updates/main Translation-en

Ign http://old-releases.ubuntu.com trusty-updates/multiverse Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-updates/multiverse Translation-en

Ign http://old-releases.ubuntu.com trusty-updates/restricted Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-updates/restricted Translation-en

Ign http://old-releases.ubuntu.com trusty-updates/universe Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-updates/universe Translation-en

Err http://old-releases.ubuntu.com trusty-backports/main Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/restricted Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/universe Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/multiverse Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/main amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/restricted amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/universe amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/multiverse amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/main i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/restricted i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/universe i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-backports/multiverse i386 Packages

  404  Not Found

Ign http://old-releases.ubuntu.com trusty-backports/main Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-backports/main Translation-en

Ign http://old-releases.ubuntu.com trusty-backports/multiverse Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-backports/multiverse Translation-en

Ign http://old-releases.ubuntu.com trusty-backports/restricted Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-backports/restricted Translation-en

Ign http://old-releases.ubuntu.com trusty-backports/universe Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-backports/universe Translation-en

Err http://old-releases.ubuntu.com trusty-security/main Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/restricted Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/universe Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/multiverse Sources

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/main amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/restricted amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/universe amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/multiverse amd64 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/main i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/restricted i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/universe i386 Packages

  404  Not Found

Err http://old-releases.ubuntu.com trusty-security/multiverse i386 Packages

  404  Not Found

Ign http://old-releases.ubuntu.com trusty-security/main Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-security/main Translation-en

Ign http://old-releases.ubuntu.com trusty-security/multiverse Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-security/multiverse Translation-en

Ign http://old-releases.ubuntu.com trusty-security/restricted Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-security/restricted Translation-en

Ign http://old-releases.ubuntu.com trusty-security/universe Translation-en_CA

Ign http://old-releases.ubuntu.com trusty-security/universe Translation-en

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/main/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/restricted/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/universe/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/multiverse/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/restricted/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/universe/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/multiverse/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/restricted/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/universe/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty/multiverse/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/main/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/restricted/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/universe/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/multiverse/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/restricted/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/multiverse/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/restricted/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/universe/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-updates/multiverse/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/main/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/restricted/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/universe/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/multiverse/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/restricted/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/universe/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/multiverse/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/restricted/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/universe/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-backports/multiverse/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/main/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/restricted/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/universe/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/multiverse/source/Sources  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/restricted/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/universe/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/multiverse/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/restricted/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/universe/binary-i386/Packages  404  Not Found

W: Failed to fetch http://old-releases.ubuntu.com/ubuntu/dists/trusty-security/multiverse/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

0 Kudos
77 Views
NXP Employee
NXP Employee

Ubuntu 14.04 is LTS, so repo for old releases should be available. But, on your Ubuntu, you get some Not Found errors. Please take a look on this link​, seems to resolved this kind of issues.

Adrian

0 Kudos
77 Views
Contributor II

Hi Adrian ,

Thank you for your answer.

The link which you mentioned did not help. Their recommendation "sudo rm /var/lib/apt/lists/* -vf" did not solve the problem.

I unchecked the other software in the Software Updates.Please see the picture below:

Screenshot from 2015-10-28 09_52_32.png

Next I tried to install CodeWarrior again. However the installation was not successful. Please the log below.

Could you give more recomendation regarding CodeWarrior installation?

Regards

Victor

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$ ls

md5sums  output.txt  README.txt  runinstall.572.dat  runinstall.574.dat  runinstall.876.dat  runinstall.955.dat  runinstall.sh  setuplinux  updates.xml

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$ ./setuplinux

The dependencies could not be automatically installed. Please try to manually install the following dependencies and then restart the installer:

libc6:i386

libgcc1:i386

gcc-4.6-base:i386

libstdc++5:i386

libstdc++6:i386

libgtk2.0-0:i386

Press any key to continue...

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$ sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

[sudo] password for ustinco:

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$ sudo apt-get update

Ign http://dl.google.com stable InRelease

Hit http://dl.google.com stable Release.gpg                                  

Hit http://dl.google.com stable Release                                      

Ign http://extras.ubuntu.com trusty InRelease                                

Hit http://dl.google.com stable/main amd64 Packages                          

Hit http://extras.ubuntu.com trusty Release.gpg                              

Hit http://dl.google.com stable/main i386 Packages                           

Hit http://extras.ubuntu.com trusty Release                                  

Hit http://repos.codelite.org trusty InRelease                       

Hit http://extras.ubuntu.com trusty/main Sources                       

Hit http://repos.codelite.org trusty/universe amd64 Packages        

Hit http://extras.ubuntu.com trusty/main amd64 Packages             

Hit http://repos.codelite.org trusty/universe i386 Packages         

Hit http://extras.ubuntu.com trusty/main i386 Packages              

Ign http://dl.google.com stable/main Translation-en_CA              

Ign http://dl.google.com stable/main Translation-en                 

Ign http://extras.ubuntu.com trusty/main Translation-en_CA

Ign http://extras.ubuntu.com trusty/main Translation-en

Ign http://repos.codelite.org trusty/universe Translation-en_CA

Ign http://repos.codelite.org trusty/universe Translation-en

Reading package lists... Done

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$ sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386 libgtk2.0-0:i386 libxpm4:i386 libusb-0.1-4:i386 libusb-1.0-0:i386 libuuid1:i386 libxcb1:i386 libnspr4:i386 libglib2.0-0:i386 libxdamage1:i386 libxtst6:i386 libssl0.9.8:i386

Reading package lists... Done

Building dependency tree     

Reading state information... Done

Package libc6:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However, the following packages replace it:

  libc-bin initscripts locales tzdata

Package libgcc1:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

Package libglib2.0-0:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However, the following packages replace it:

  libglib2.0-bin

Package libgtk2.0-0:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However, the following packages replace it:

  libgtk2.0-common libgdk-pixbuf2.0-0

Package libstdc++6:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

Package libnspr4:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

Package libxdamage1:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

Package libxtst6:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

Package libuuid1:i386 is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However, the following packages replace it:

  e2fsprogs

E: Package 'libc6:i386' has no installation candidate

E: Package 'libgcc1:i386' has no installation candidate

E: Unable to locate package gcc-4.6-base

E: Couldn't find any package by regex 'gcc-4.6-base'

E: Unable to locate package libstdc++5

E: Couldn't find any package by regex 'libstdc++5'

E: Package 'libstdc++6:i386' has no installation candidate

E: Package 'libgtk2.0-0:i386' has no installation candidate

E: Unable to locate package libxpm4

E: Unable to locate package libusb-0.1-4

E: Couldn't find any package by regex 'libusb-0.1-4'

E: Unable to locate package libusb-1.0-0

E: Couldn't find any package by regex 'libusb-1.0-0'

E: Package 'libuuid1:i386' has no installation candidate

E: Unable to locate package libxcb1

E: Package 'libnspr4:i386' has no installation candidate

E: Package 'libglib2.0-0:i386' has no installation candidate

E: Package 'libxdamage1:i386' has no installation candidate

E: Package 'libxtst6:i386' has no installation candidate

E: Unable to locate package libssl0.9.8

E: Couldn't find any package by regex 'libssl0.9.8'

ustinco@ustinco-Inspiron-530s:~/Documents/Belfast/CW2/disk1$

0 Kudos