compiling only in arm mode in CW 10.5

cancel
Showing results for 
Search instead for 
Did you mean: 

compiling only in arm mode in CW 10.5

392 Views
stefanomanca
Contributor III

Hi, where I find the menu to set the compiler only in ARM mode (not thumb)?

 

Thank you.

 

Stefano M.

Labels (1)
Tags (3)
0 Kudos
3 Replies

123 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello Stefano:

That option is in Project -> Properties -> C/C++ Build -> Target Processor.

:smileyalert: BUT if you are using a Kinetis L or Kinetis K device, then you must not uncheck that option, since Cortex M0 and Cortex M4 only support thumb mode, and you will receive errors during compile time.

Thumb.png

Hope this helps!

Jorge Gonzalez

0 Kudos

123 Views
stefanomanca
Contributor III

Hi Jorge, I don't understand. I'm using a kl15, it should have a cortex m0+ core, but I get

"/Sources/ProcessorExpert.c:1:0: error: target CPU does not support ARM mode

mingw32-make: *** [Sources/ProcessorExpert.o] Error 1"

So, what happens?

I'm not so skilled.

Thank you.

0 Kudos

123 Views
Jorge_Gonzalez
NXP Employee
NXP Employee

Hello:

That is the error I mentioned. Cortex M0+ in your KL15 cannot support ARM mode instruction set. You need to check that option back, so the compiler uses the thumb instruction set.

To double check this info, take a look at the specifications tab from the next link at ARM web page:

http://www.arm.com/products/processors/cortex-m/cortex-m0plus.php

Regards!

Jorge Gonzalez

0 Kudos