Codewarrior 10.3 on Linux

cancel
Showing results for 
Search instead for 
Did you mean: 

Codewarrior 10.3 on Linux

Jump to solution
8,011 Views
bob_walker
Contributor III

When will CW10.3 be released for Linux?

Labels (1)
1 Solution
247 Views
BlackNight
NXP Employee
NXP Employee

There are no plans for 10.3 and Linux. Alternatives on Linux are CodeRed or Cocox.

View solution in original post

0 Kudos
30 Replies
39 Views
tassiloböhr
Contributor I

Erich Styger schrieb:

There are no plans for 10.3 and Linux. Alternatives on Linux are CodeRed or Cocox.

So there is no chance anymore to code and debug HCS08 devices under linux with an up-to-date ide / toolchain?

Tassilo

0 Kudos
39 Views
cicero_ribeiro
Contributor I

can I find download link for codewarrior ide 10.2 for linux ?

Thanks.

0 Kudos
39 Views
Monica
Senior Contributor III

Cicero, here is the page where you can find the many editions and updates for CodeWarrior.

Regards!

CodeWarrior Downloads

0 Kudos
39 Views
Monica
Senior Contributor III

More specifically, you can find 10.2 and 10.3 versions right here under the "Software Development Tools" tab! CodeWarrior for MCU. Enjoy everyone!

0 Kudos
39 Views
cicero_ribeiro
Contributor I

Thanks for reply Monica,

But I can't see any version for linux.......    :smileysad:

Maybe you talk about  Power Architecture Eclipse Software

but I'm looking for s08 microcontrollers.

0 Kudos
39 Views
Monica
Senior Contributor III

Cicero, the Linux hosted Software is being uploaded in this very moment. You'll be able to see it there tomorrow (10.2)

Please let me know if you need anything else!

39 Views
cicero_ribeiro
Contributor I

Thanks Monica.

0 Kudos
39 Views
bob_walker
Contributor III

Are you saying that Freescale has abandoned any and all tools that run on the Linux platform?!

CW10.2 is the LAST version for Linux?!

If this is the case, then WHAT is the reason for dropping Linux and where did this mandate come from?

0 Kudos
39 Views
JimDon
Senior Contributor III

Just codewarrior. Freescale supports many BSPs and tools on linux, just not  codewarrior any more.

If you had purchased a license, you may be able to get a refund.

0 Kudos
39 Views
bob_walker
Contributor III

I see. So in order to use Codewarrior 10.3 we will need to purchase a Microsoft license for Winxxx instead of using our Linux machines which worked just fine with Codewarrior 10.2.

If Freescale cannot support our platform of choice, then we will no longer support Freescale (i.e. no more Freescale designs.). Our company does not do Windows due to the security risks associated with that OS.