Codewarrior 10.3 on Linux

cancel
Showing results for 
Search instead for 
Did you mean: 

Codewarrior 10.3 on Linux

Jump to solution
8,012 Views
bob_walker
Contributor III

When will CW10.3 be released for Linux?

Labels (1)
1 Solution
248 Views
BlackNight
NXP Employee
NXP Employee

There are no plans for 10.3 and Linux. Alternatives on Linux are CodeRed or Cocox.

View solution in original post

0 Kudos
30 Replies
208 Views
yibbidy
Contributor V

Darn, I just heard the news after trying to find the new Linux version at Freescale.  Hmmm... what to do, I currently have a S08 product and an upcoming Coldfire V2 project.  I suppose I could eventually move to CodeSourcery for the Coldfire project, but I'm screwed for updates for S08.  Might be time to consider another silicon vendor :smileysad:.

0 Kudos
208 Views
BlackNight
NXP Employee
NXP Employee

Hi James,

are the S08 and V2 parts you are talking about not covered in 10.2?

0 Kudos
208 Views
yibbidy
Contributor V

Hi Erich,

The parts are covered by CW 10.2.  I was more concerned about any future bug fixes or additional devices which might be released will not be supported.  I am right for today, but at some point I will need to migrate if CW 10.2 is abandoned. 

0 Kudos
208 Views
BlackNight
NXP Employee
NXP Employee

The S08 and ColdFire tools has been very stable since 10.1, at least for me. Not much (if anything) has been changed. Looking at the Freescale roadmaps, anyway most new devices are on Kinetis/ARM. So you decide to stay on S08/CF, then 10.2 should be ok. But if you are planning to use Kinetis/ARM, then you would need >10.2, but then you have different options from different vendors.

0 Kudos
208 Views
yibbidy
Contributor V

Thanks for that Erich, that's good to know as I don't want to have to change tools half way through the project.

0 Kudos
208 Views
yvesbalderacchi
Contributor I

There is a good alternative if you want to work on linux based PC : you can use Redsuite .

It's very well explained here:

http://mcuoneclipse.com/2013/04/20/red-suite-5-eclipse-juno-processor-expert-and-unlimited-frdm-kl25...

I tried it with my FRDM-KL25 board on a linuxmint based PC.

If you want to  use processor expert with RedSuite, you need a beta version, that you can ask to support Redsuite.

The current version (v5.2.4 Build 2122 MAY 2013 ) doesn't work well under linux. You can't use processor expert.

They gave me the Red_Suite_5_5.2.5_2131_beta_Linux-x86.

This one is OK !

You need after to put the right debug driver, as it's explained here:

http://support.code-red-tech.com/CodeRedWiki/KinetisSupport

And after you can use the FRDM-KL25 under linux.

Enjoy it


0 Kudos
208 Views
georglerm
Contributor I

Seems like I am having a problem with CodeRed not seeing the board when I switch to debug.

I can see it in the dmesg output.

83.116541] usb 2-1.2.3: Product: Redlink-FRDM-V1_02

[   83.116549] usb 2-1.2.3: Manufacturer: Code Red Technologies Inc.

[   83.118072] hid-generic 0003:21BD:0006.0004: hiddev0,hidraw2: USB HID v1.00 Device [Code Red Technologies Inc. Redlink-FRDM-V1_02] on usb-0000:00:1d.0-1.2.3/input0

Also checked that the udev rules are there, but still no go.

Did you have a similar problem with v5.2.4 Build 2122 ?

0 Kudos
208 Views
georglerm
Contributor I

Seems that Xubuntu 13.xx has something broken surrounding the usb lib/drivers.

I installed Xubuntu 12.04.2LTS 32 bit  earlier today. Installed Code Red as per instructions above.

Just used the example code supplied to test, and it compiles and debugs!!!:smileyhappy::smileylaugh:

Running  on 12.04.2LTS. Will do some further testing during this week.

Hope this help some of the other users that want to use linux instead of windows.

0 Kudos
208 Views
yibbidy
Contributor V

Thanks for the link Yves. I checked it out and notice that it is only for ARM based Microcontrollers. Nice that they support Mac too. I also notice that they have just been acquired by NXP and from next year will only support NXP Microcontrollers. You may have to move tools sometime too. Given that I haven't moved to ARM, and that Freescale do not support development on Linux, and most others do, if I did move to ARM I would probably change silicon vendors.

Thanks again,

Shaun

0 Kudos
212 Views
injunear1
Contributor IV

If I may, I would like to ask why Freescale requires that we pay one of the richest men in the world, Bill Gates, a tribute of $70 to $140 (for his OS) in order to simply use a Freedom board? CodeWarrior 10.3  only runs on Windows (or Mac, in which case one pays tribute to Apple).

The only reason I currently use a Windows machine is to program for the Freedom board and make these posts. (The website supported Linux a month or two ago. Why do they no longer allow Linux posters?)


(Windows is an inferior unsafe operating system that gives Microsoft, and countless others, full access to all the data on ones computer unless the user knows which changes to make in the convoluted registry, and then pay other companies for their security software. )

Is it really that hard to include Linux support on the website and in CW 10.3?

I am not trying to be belligerent. The difference between Linux and Windows is a whole lot more than geeky user preference.

Thank you.

212 Views
bob_walker
Contributor III

We netted >$1M from products using Freescale processors last year. Granted, that's chump change for Freescale. The thing that really irks me is that Freescale, as well as other companies whose names I won't mention, have no problem exploiting the open source community (e.g. Eclipse Foundation) for their own purposes, while not reciprocating (i.e. NOT supporting the open source community). The fact that my second question went unanswered is telling.

Our decision to switch to NXP for our ARM solutions is directly a result of Freescale's decision to not support the Linux platform. The fact is, CW10.2 worked just fine...so WHY is it no longer available?

The bottom line for us is that Linux is THE OS and platform for engineering work. UNIX is our second choice. Our mechanical CAD and FPGA vendors have native Linux apps that we use. Software SHOULD be platform agnostic. Period, the end!

If you can't do that, we don't need you.

208 Views
Alberto_g
Contributor III

Same situation here. Windows is used ONLY for the Freescale tools.

I'm not sure we will stay with them for our next projects.

Hope someone will reconsider a bad decision.

0 Kudos
212 Views
JTech
Contributor III

I am also moving away from Freescale because of their decision to drop Linux support. I cannot and will not use Windows anymore. I refuse to give Bill Gates any more of my hard-earned cash for an insecure operating system that opens me up to people spying on me (including governments) Last year my desktop PC was infiltrated and I am tired of Windows being so insecure and so useless. I made the switch to KUbuntu and that's it!

Freescale is the only semiconductor vendor whose products are not supported in Linux and its a shame really. Good silicon, but very poor decisions to kick the open source community and the paranoia about the devtools is astounding, the IDE is so full of DRM its scary. This is a mistake that will cost Freescale dearly in the end, mark my words.

I have had to install Windows XP to get the Classic V6.3 Codewarrior to work, the Eclipse version is just horrible and I really don't care if it works for some, it doesn't work for me, neither on Windows 7, nor XP nor on several different machines. I get NO support, except some people in this community basically saying in convoluted language I am stupid etc...

If Freescale were smart, they would focus on silicon sales, and de-classify the development tools, or provide a Linux version of the classic IDE.

I am now at the stage in my life, with > 8 successful products on the market that I will no longer stand for inflexibility from a semiconductor vendor. They don't want to come to the party, I will use someone else's silicon. Simple as that.

208 Views
christophersmit
Contributor I

I'd like to second this.  The Kinetis line looks like a great family of products, and I was excited about it as a replacement for constrained AVR MCUs, but locking out developers--especially the new generation of embedded developers that's growing up on the Arduino and mbed systems--is a bad move.  I particularly like the business assurance of using GCC with the AVR platform, and I find it especially ironic that Freescale is closing off Linux support for an Eclipse-based development platform.  The contrast in the message to customers between the CodeWarrior group and the mbed group makes it look as though Freescale has some serious left-hand-right-hand problems, and that's a big red flag to someone choosing a new development platform.

249 Views
BlackNight
NXP Employee
NXP Employee

There are no plans for 10.3 and Linux. Alternatives on Linux are CodeRed or Cocox.

View solution in original post

0 Kudos
212 Views
yibbidy
Contributor V

BlackNight, are there going to be any more updates/patches for CW10.2 on Linux or has the plug been pulled completely?

0 Kudos
212 Views
BlackNight
NXP Employee
NXP Employee

Hi James,

there are no plans for updates/patches for 10.2 on Linux.

0 Kudos
212 Views
jcottier
Contributor II

Cant find anything with respect to Cocox, and Coocox is Windows only (for Cortex ARM core chips). So it looks like there is no Linux version that supports Freescale ARM cored chips or HCS08.

0 Kudos
212 Views
jcottier
Contributor II

CodeRed is not an option. They have been bought by NXP and are dropping all support for none NXP chips. So that leaves Cocox (or is that Coocox?).

0 Kudos
212 Views
bikenomad
Contributor III

This is very short-sighted. We use Linux as our build environment for the Freescale i.MX parts, and have been using CW 10.2 under Linux (which compiled faster than CW 10.2 under Windows, interestingly).

0 Kudos