CW5.7 + PK-HCS12E128 + Processor Expert

cancel
Showing results for 
Search instead for 
Did you mean: 

CW5.7 + PK-HCS12E128 + Processor Expert

Jump to solution
1,517 Views
onamatic
Contributor I
I'm trying to work with some old projects I created with CW3.1 for the PK-HCS12E128 evaluation board.
 
I have lost the original installation along with the CW3.1 update so have installed CW5.7 and the original  Softec drivers from CD on W2K Server SP4.
 
All works fine for straight C projects, BUT Processor Expert is totally broken, even for the given Softec ADC example project. Loading this project gives this error:
Code:
The following access path in target "SofTec" of project "ADC.mcp" cannot be found:{Compiler}bin\Plugins\support\ProcessorExpert\PESL\HCS12The following access path in target "SofTec" of project "ADC.mcp" cannot be found:{Compiler}bin\Plugins\support\ProcessorExpert

 
I removed those paths (as indeed they did not exist) but was then met with further PE problems saying that there was was no valid license file for adc.sys, mpu.sys, ...  (I think that's what they were called).
 
Is there some other license for PE or some installation procedure I need to carry out? I am currently using the evaluation license.dat that came with CW5.7.  It does not appear to have any entries for PE.
 
Any advice gratefully received!
 
 
Labels (1)
Tags (1)
0 Kudos
1 Solution
102 Views
CrasyCat
Specialist III
Hello
 
- Which version of CodeWarrior are you using?
To retrieve that info:
- Start CodeWarrior
- Select Help -> About Freescale CodeWarrior
- Click on "Install Products"
- CodeWarrior version used is displayed on top in the Installed Products dialog.
 
I know that support for PESL has been removed from ProcessorExpert version 2.96.
You may Check with Softec if they have an updated version of the project working with the latest CodeWarrior (& ProcessorExpert) releases.
 
Also there is an ADC sample projects in the {Install}\ProcessorExpert\Projects\Test projects directory.
You may want to try with this one.
 
I hope this helps.
 
CrasyCat

View solution in original post

0 Kudos
2 Replies
103 Views
CrasyCat
Specialist III
Hello
 
- Which version of CodeWarrior are you using?
To retrieve that info:
- Start CodeWarrior
- Select Help -> About Freescale CodeWarrior
- Click on "Install Products"
- CodeWarrior version used is displayed on top in the Installed Products dialog.
 
I know that support for PESL has been removed from ProcessorExpert version 2.96.
You may Check with Softec if they have an updated version of the project working with the latest CodeWarrior (& ProcessorExpert) releases.
 
Also there is an ADC sample projects in the {Install}\ProcessorExpert\Projects\Test projects directory.
You may want to try with this one.
 
I hope this helps.
 
CrasyCat

View solution in original post

0 Kudos
102 Views
onamatic
Contributor I
Thank you for helping me!

My CW version is v4.6 Build 6345 (which is odd because I thought I downloaded CW5.7 - getting old!)

PE is version is 2.97  ( CW Plugin IDE version 3.83 L2 ).  That confirms your assertion about PESL support being removed.

Following your suggestion I have now successfully compiled the ADC project with a simulator target,  "all" I have to do now is set up a Softec target for the PK-HCS12E128 (which I don't have a clue about!).  I might then have a chance of converting my old 3.1 projects, possibly, perhaps!

Thanks again for your help
0 Kudos