why the .s file created by codewarrior 10.6 is not accepted by Cyclone for ARM Devices?

cancel
Showing results for 
Search instead for 
Did you mean: 

why the .s file created by codewarrior 10.6 is not accepted by Cyclone for ARM Devices?

Jump to solution
418 Views
maqindong
Contributor II

here is a problem i meet when i use the Cyclone for ARM devices tool to download codes to the target KE02Z64----the Cyclone for ARM devices tool gives the error "$3003: Program operation failed or canceled". the .s file i use to configure the Cyclone for ARM devices tool is generated by CW 10.6 by setting the codewarrior as Fig 1 shows. actually the same error comes out when i use the .elf file generated by CW. the Cyclone for ARM devices tool configuration information is shown in Fig.2.

22283_22283.png捕获.PNG.png

                                                                            Fig.1

22284_22284.png111.PNG.png

                                                           Fig.2  Cyclone for ARM devices configuration

p.s. the contents of .hex file is .s record  actually.

p.p.s the codes is correct, because it has been verified by downloading to the target with P&E multilink universal tool.

is there anybody to know how to get it done?

Labels (1)
1 Solution
145 Views
maqindong
Contributor II

I run the Cyclone successfully after i updated the Cyclone version to v1.59 because the early version of Cyclone doesn't support KEx MCUs. thanks a lot for your help,Carlos_Mendoza.

View solution in original post

5 Replies
145 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi MA QINDONG,

In CodeWarrior the extension of the generated flash image is always *.hex, even if it is a S-Record file. Please try renaming the file to *.S19,  which is one of the supported object files by the Cyclone for ARM and let us know if it works.

Hope it helps!

Best Regards,

Carlos Mendoza

Technical Support Engineer

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos
145 Views
maqindong
Contributor II

morever, i have checked the .s19 file contents' checksum calculation. and the checksum is right. is there any else methods to resolve this?

0 Kudos
145 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi MA QINDONG,

Have you tried updating to the latest Cyclone for ARM software? that might solve some issues.

If the issue persist I would recommend you to contact P&E support, here is the link:

P&E Microcomputer Systems

Hope it helps!

Best Regards,

Carlos Mendoza

Technical Support Engineer

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos
146 Views
maqindong
Contributor II

I run the Cyclone successfully after i updated the Cyclone version to v1.59 because the early version of Cyclone doesn't support KEx MCUs. thanks a lot for your help,Carlos_Mendoza.

View solution in original post

145 Views
maqindong
Contributor II

hi, Carlos Mendoza, i have done as you advised. but i didn't work. when i run the "Execute SAP Function"->"Verify Data in Target",and the error the Cyclone gives is "$000050003" as the picture shows,which means that "Verification operation failed or canceled".

img_0541.jpg

0 Kudos