migration CW7 to CW10 unknow error illegal type qualifier

cancel
Showing results for 
Search instead for 
Did you mean: 

migration CW7 to CW10 unknow error illegal type qualifier

215 Views
perriaufabrice
Contributor I

hello

 

I migrate our software from CW7 to CW 10 on ecplis. evrering is working i connected our EPLD to MCF5235 led  are blinking.

then i added all our file.h and i got an error. i never seen this error illegal type qualifier.

this error took place in exceptions.c file.

 

if someone have an idee do not hesitate to help me

..36081_36081.pngSans titre.png

Labels (1)
0 Kudos
3 Replies

120 Views
perriaufabrice
Contributor I

hi Pascal

thanks for your answer, we are moving from MCFV7.0 to MCU10.5

i look at the console but i don't realy understand

Should i try to export from MCF7.0 to MCF7.3 ?

Fabrice

error.png

0 Kudos

120 Views
trytohelp
NXP Employee
NXP Employee

Fabrice,

Sorry the last version is MCF V7.2 and not V7.3 (which is not existing).

Moving CW for MCF V7.0 project to MCU V10.5 is a big jump because we changed the libraries MSL to EWL.

In some case it could be interresting to split the operation in more steps which could be:

    1- import project on CW for MCF V7.2

          Refer to the TN268 attached.

    2- be sure the application is running on V7.2.

    3- import the project on MCU V10.5 or V10.6.

Regarding your problem with __declspec, please have a look to the attached doc.

Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

120 Views
trytohelp
NXP Employee
NXP Employee

Hi Fabrice,

Can I recommend to have a look to the Console component instead of the Problem one ?

The console will provide more information regarding the error.

You try to move your CW for MCF V7.x application to MCU V10.x.

To avoid problem it's better to have a running application under CW for MCF V7.3 which is the last version based on classic IDE for Coldfire device before to port it under MCU V10.x.

We've a note giving more information.

            AN4104, Converting ColdFire Projects to CodeWarrior Development Studio for Microcontrollers V10.0

                        http://cache.freescale.com/files/soft_dev_tools/doc/app_note/AN4104.pdf

Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos