Unable to write S08 flash in run mode

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to write S08 flash in run mode

Contributor I

Hello Everyone,


I'm using S08QE8 controller flash in my project and got standard routines for S08 flash writing which I have attached for the reference.


However, i am stuck with a strange problem... and need help.


I am trying to program 22 bytes in flash using burst mode. When I place a break point after checking the flash command buffer empty flag (FCBEF) in debug mode each byte get programmed in flash correctly.


But while executing the same code in run mode it gives error massage saying, "No source available for "0x0000" or sets Flash and RAM to 0xFF

I thought it might be because of delay issue in first byte and second byte write so tried to provide delay in between, but it doesn't worked.

Code seem correct as it is working fine in debug mode. Will be glad if anyone can help.


Original Attachment has been moved to: S08_Flash.h.zip

Original Attachment has been moved to: S08_Flash.c.zip

Labels (1)
0 Kudos
1 Reply

NXP Employee
NXP Employee

Please try the attache code!

0 Kudos