AnsweredAssumed Answered

compile error u-boot-fw-utils under yocto zeus

Question asked by Nikhil sahu on May 25, 2020
Latest reply on Jun 14, 2020 by Wigros Sun

I am trying to compile the u-boot-fw-utils under yocto zeus. Earlier i was getting compilation error but somehow imanages to replace my config with mx6sxsabresd_optee_defconfig as defined in default configuration.

 

below are steps for compilation.

  1. repo init -u https://source.codeaurora.org/external/imx/imx-manifest  -b imx-linux-zeus -m imx-5.4.3-1.0.0.xml
  2. repo sync
  3. Rename my config with mx6sxsabresd_optee_defconfig
  4. DISTRO=fsl-imx-fb MACHINE=imx6sxsabresd source imx-setup-release.sh -b build_sabres
  5. bitbake u-boot-fw-utils

 

I am getting below error 

=================================================

rm -f .tmp_quiet_recordmcount

make -f ./scripts/Makefile.build obj=scripts/kconfig syncconfig

mkdir -p include/config include/generated

scripts/kconfig/conf --syncconfig Kconfig

.config:160:warning: symbol value '' invalid for SYS_TEXT_BASE

*
* Restart config...
*
*
* Boot images
*
Enable support for Android Boot Images (ANDROID_BOOT_IMAGE) [Y/n/?] y
Support Flattened Image Tree (FIT) [N/y/?] n
Enable support for the legacy image format (IMAGE_FORMAT_LEGACY) [Y/n/?] y
Set up board-specific details in device tree before boot (OF_BOARD_SETUP) [N/y/?] n
Set up system-specific details in device tree before boot (OF_SYSTEM_SETUP) [N/y/?] n
Update the device-tree stdout alias from U-Boot (OF_STDOUT_VIA_ALIAS) [N/y/?] n
Extra Options (DEPRECATED) (SYS_EXTRA_OPTIONS) [IMX_CONFIG=board/freescale/mx6sxsabresd/imximage.cfg] IMX_CONFIG=board/freescale/mx6sxsabresd/imximage.cfg
Text Base (SYS_TEXT_BASE) [] (NEW)
Error in reading or end of file.

Text Base (SYS_TEXT_BASE) [] (NEW)
Error in reading or end of file.

Text Base (SYS_TEXT_BASE) [] (NEW)
Error in reading or end of file.

Text Base (SYS_TEXT_BASE) [] (NEW)
Error in reading or end of file.

 

<stuck in Infinite loop>

================================================

Default script flag is not setting here. Anyone suggested how to overcome with this.

Also if anyone compiled standalone u-boot-fw-utils just like kernel and u-boot. Please suggest.

 

Thanks,

Nikhil

Outcomes