AnsweredAssumed Answered

CAN resource is not owned in the IMX8QM MEK as i am using imx-p9.0.0_2.0.0-ga version of code?

Question asked by Pooja Kumari on Jul 10, 2019
Latest reply on Jul 16, 2019 by Pooja Kumari

I am using imx-p9.0.0_2.0.0-ga version of IMX8QM MEK board. I want to enable the FLEXCAN resource . But in this version of code it is saying CAN resource is not owned. I am trying to enable in u-boot  changing status is "okay" but it is disabling the resource by reverting back the status. It is saying "Disabled CAN ,resource id not owned". I have tried to enable this in IMX8QXP MEK board also with imx-p9.0.0_2.0.0-ga latest version but in this also it is saying "resource not owned".

Kindly help me How to own Flexcan resource in this version imx-p9.0.0_2.0.0-ga as we need to use the latest version of code.

FYI In previous version imx-p9.0.0_1.0.0-ga this CAN resource is enabled by default.

 

 

I have tried to use mx8qm.scfw.tcm.bin  binary file of imx-p9.0.0_1.0.0-ga version of code with my version of code imx-p9.0.0_2.0.0-ga by replacing my mx8qm.scfw.tcm.bin file. But it is not booting with my code. I have read somewhere to change this scfw.bin file flexcan would work . So i have tried with working version of imx-p9.0.0_1.0.0-ga binary file. I am getting stuck at u-boot time.
Can anyone suggest or tell how this issue is resolved?

Can anyone tell how the flexcan resource is owned?

Outcomes