AnsweredAssumed Answered

[SOLVED] LPC-Link Debug Error

Question asked by Federico Fiorini on Dec 12, 2018
Latest reply on Dec 13, 2018 by Federico Fiorini

Hi, 
I am working with the LPCXpresso LPC11C24 board using USB to flash code on the board and to debug it, but I keep getting the error

 

MCUXpresso IDE RedlinkMulti Driver v10.2 (Jul 25 2018 11:29:34 - crt_emu_cm_redlink build 555)

Reconnected to existing link server

Connecting to probe 1 core 0:0 (using server started externally) gave 'OK'

Probe Firmware: LPC-Link Probe v1.3 (NXP - LPC-Link)

Serial Number:  WIN64HS12

VID:PID:  1FC9:0009

USB Path:

connection failed - Em(19). Communications with DAP fails - is probe connected to a target?.. Retrying

Failed on connect: Em(19). Communications with DAP fails - is probe connected to a target?

Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>

Last stub error 0: OK

Last sticky error: 0x0 AIndex: 0

No debug bus (MemAp) selected

DAP Speed test unexecuted or failed

Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.

(100) Target Connection Failed

 

This is happening ever since I tried the DEEP SLEEP mode on the LPC11C24. 
I tried using the RESET pin on PIO0_0 but apart from LED2 toggling nothing happens...


Do you know what should I do? 

Outcomes