AnsweredAssumed Answered

Use SDIO Murata module with i.MX8MQ

Question asked by Théo Goudout on Dec 12, 2018
Latest reply on Aug 9, 2019 by Bill Chen

Hi,

 

I'm trying to get a Murata 1MW EVK module to work with a i.MX8MQ EVK.

 

So far, I've compiled a Yocto using the scripts provided by Murata at https://github.com/murata-wireless/meta-murata-wireless ; I've configured it as follow :

 

Release Type: Developer (When using "Stable", the generated tag does not exists on the github repository...)

Processor: i.MX

fmac version: manda (recommended)

i.MX Yocto Release: imx-rocko-mini-manda

Target: imx8mqevk

 

I then proceeded to flash a SD card with the generated "*.sdcard" file and successfully booted my i.MX8MQ evaluation kit. At this point, I would expect to see a wireless interface associated to the on-board 1CQ module.

 

Now this is where it gets tricky :

  • I don't have any wireless interface showing when using "ifconfig", "ip addr" or "iw list";
  • I cannot see anything related to fmac module being loaded by the kernel during boot;
  • I can manually load these modules using "modprobe brcmutil" and "modprobe brcmfmac", but still no wireless interface shows up;
  • I've tried to load different FDT from the u-boot command line ("fsl-imx8mq-evk.dtb", "fsl-imx8mq-evk-root.dtb" and "fsl-imx8mq-evk-pcie1-m2.dtb") with no luck.

 

Even if I actually saw a wireless interface, it is not my final objective. I would still need to :

  • Flash the content of the SD card to the eMMC (to free up the microSD connector);
  • Connect my 1MW module to the microSD using the "Murata i.MX InterConnect V1" and a SD-to-MicroSD adapter;
  • Connect the remaining WL_HOST_WAKE, BT_REG_ON and WL_REG_ON cable somewhere on the board (where?!);
  • Probably rework/patch the FDT used by the i.MX8 family;
  • Something else?

 

Could you help me sort my problem out?

 

Regards,

Outcomes