AnsweredAssumed Answered

HardFault problem in KDS using K22F

Question asked by Jace Walton on Dec 21, 2016
Latest reply on Jan 18, 2017 by Alice_Yang

How do i get code to run on my mk22f?

on Windows 7

using Jlink bootloader. (Have used PE Micro with same results)

Kenitis Development Studio v3.2.0. (have also Tried IAR and mbed same result)

SDK: SDK_2.1_FRDM-K22F

 

I am using the demo projects located at. 

C:\Freescale\SDK_2.1_FRDM-K22F\boards\frdmk22f\demo_apps

 

The projects will build and download. I can enter the debugger and step through the code but, the functionality of the projects does not show, meaning that Bubble demo does not show red or blue LED's when the board is tilted. also the Hello world program does not blink LED's or show anything on the terminal. 

During the running of the bubble demo I can step through the code to the highlighted line

At that point I can no longer step through the code when I halt (pause) the code I am taken to this line.

What is a HardFault, is this why my code won't run? or is there something else causing this?

attached is a zip of my project incase that is needed.

 

My steps were.

Import bubble project

Clean all

Build Project (Debug)

Debug Project as JEGGER J-Link

Step over function. 

HardFault.

 

Ideas?

Original Attachment has been moved to: bubble.zip

Outcomes