AnsweredAssumed Answered

Flashing problem

Question asked by bilel ben elghali on Sep 1, 2015
Latest reply on Sep 9, 2015 by bilel ben elghali

Hi everybody,

I am using Kinetis KV31F256m12 package with 64 pins KSDK 1.2 on IAR Embedded workbench v7.2 and  the JLink as flashing tool.

I have already downloaded my program several times on the board and it worked very well but since yesterday I am facing the following problem when trying to download the same program on the same board with the same configuration and tools IAR cannot download the program and show me the following message :

---- Fatal error: Kinetis (connect): Timeout while halting CPU. CPU does not stop.   Session aborted!--------

and when I tried to use the command lines to control Jlink the command halt does not work ------cannot halt CPU------

And when watching the reset pin which is supposed to be at high state 3.3V in our case we found that it is at 1V so we tried to force it to 3.3V but we got the same message ---cannot halt CPU---

We checked the pin PTA4  and is high.

Other remark, we noticed that there is a potential of 1.5V on the pin PTA1.

It seems like if the CPU is stacked in the reset state and cannot leave that state.

Also when we tried the hwinfo command on the Jlink Commander it show this in his message: HWInfo[00]=Target power is disabled

 

 

Also when we tried to download the program on an other similar board it worked very well very well.

 

Can you help me please.

Thanks.

Outcomes