AnsweredAssumed Answered

arm-none-eabi-edb.exe in KDS 3.0.0 failing after J-link firmware update

Question asked by Lee Shaver on Aug 28, 2015

I've run into an issue after updating the firmware in my J-Link Ultra+ to the newest revision. Now, when debugging, arm-none-eabi-edb.exe crashes almost immediately, ending the debug session.

 

Target processor: MKV31F128VLH10 (64-pin LQFP)

 

Above: the error message

Above: arm-none-eabi-edb.exe console, which also reports an exit value of 255

GDB server log was a fair big bigger, so it's attached.

 

I've been working on this project for some time without issue before installing the J-link firmware update. I have updated the J-link firmware previously without issue. I have not found a proven safe method of updating the failing executable, given that KDS uses it's own installed version.

 

Attempted steps taken to solve problem:

Updated KDS via "Help -> Check for Updates". It found a small number, including an update from PEx 3.0.0 -> PEx 3.0.1. Also listed was changes to how debugging profiles are handled. With the updates installed a number of bugs with debug profiles surfaced. In particular I was unable to view or create SEGGER profiles. I did confirm that the profile still existed on the drive; KDS was just unable to handle it, and was unable to create new ones.

 

I downloaded the newest SEGGER drivers and tools (V5.00 as shown in the attached log). With these and the version installed in KDS I confirmed that I can contact the chip, as before. JLinkRTTViewer continues to work for RTT communication. I also was able to launch the GDB server successfully with the SEGGER tools, without apparent issue. I also confirmed that the firmware properly installed and was the latest version (I did not see an easy method of rolling back the firmware).

 

I uninstalled KDS 3.0.0, and got a fresh installer from freescale.com (I hope the Java-based downloader is gone by the time I have to download anything else; that was unpleasant). Having installed the supposed newest version, I returned to seeing the above (original) error message. The updates that caused issues above were still available (not in the "newest" install), so I went ahead with them as a test, with the same result. This time I ran the repair utility on the new installer on the new install, which seems to have fixed the post-update issue with debug profiles. Somewhat sadly, however, I'm back to seeing the original error message shown at the top.

 

Any suggestions would be appreciated.

Original Attachment has been moved to: GDB_server_log.txt.zip

Outcomes