AnsweredAssumed Answered

How to deal with MDM-AP Status System Security bit set on new MKL26Z

Question asked by Neil Hancock on Aug 19, 2015
Latest reply on Sep 8, 2015 by Neil Hancock

Hi, I’m bring up a new revision of a MKL26Z128VFT4 board.

I have one board working previously and the numbers on the MKL26Z are all the same indicating same batch, but the devices where purchased at separate times from Digikey

However this new PCB revision has the reset pulse every 3us – 2us in reset and then 1us released – pulled up with a 10K. Generated internal in the MK26Z

The Reset, NMI pin, SWD_DIO pin are pulled up through 10K, and SWD_CLKI pulled to 0V  through 10K. All worked on the previous revision of the board.

I’m using a KDS3 with J-Link with (sw latest v5.0l) to program – and it keeps getting “Timeout while unlocking device” “Timeout while unsecuring device”

I did initially have the bad update for KDS3, that had a problem with a plugin - but I've udpated the plugin - and dropped to looking a the MDM-AP register directly

On doing a lot of reading here and elsewhere (thanks for the community discussions ),

using J-Link Commander I read the devices MDM-AP register

and it appears bit 2 “system Security” is set.

I have read AN485, tried suggestions for running a unlock script from mcuOnEclipse.com,

but nothing has worked, and I can't program the Flash to get it out of its reseting.

Any insights/suggestions for next steps appreciated.

 

J-Link>device ?

Info: Device "MKL26Z128XXX4 (ALLOW SECURITY)" selected.

Reconnecting to target...

Info: Found SWD-DP with ID 0x0BC11477

 

****** Error: Kinetis (connect): Timeout while unsecuring device. Erase never starts.

Kinetis (connect): Failed to unsecure Kinetis device.

J-Link>unlock kinetis

Unlocking device...Timeout while unlocking device.

J-Link>SWDreadAP 0x1000000

Read AP register 16777216 = 0x00000036

J-Link>SWDreadAP 0x1000000

Read AP register 16777216 = 0x00000034

J-Link>SWDreadAP 0x1000000

Read AP register 16777216 = 0x00000034

  J-Link>

Outcomes