AnsweredAssumed Answered

Can you get a dump of the SGTL5000 codec registers?

Question asked by Ian Craig on Jun 16, 2015
Latest reply on Jun 22, 2015 by Fabio Estevam

Hi

 

On my new iMX6Quad board I'm having issues getting the SGTL5000 audio codec to work. What is happening is the codec is getting initialised and the I2S clock is getting turned on at the end of initialisation but the clock turns off a few milliseconds later. I want to try and get a dump of the code registers after this point to see if the chip has been reset for some reason (supplies are fine),

 

I have taken a trace of the I2C traffic and this looks ok. The only thing I have noticed is if you run aplay once the system is up the top two bits of register CHIP_ADCDAC_CTRL are set. These indicate "Volume Busy DAC Right & Left". I have a reference working system and these bits are never set.

 

I have tried "cat /sys/devices/soc0/sound.17/HiFi/codec_reg" but get nothing back. I have also tried this via debugFS with the same result. Is there any other way to dump these registers?

 

Thanks

Outcomes