AnsweredAssumed Answered

gstreamer display embedded subtitles

Question asked by Lachezar Nikolov on Jan 6, 2014
Latest reply on Mar 31, 2014 by Yixing Kong

Hello,

 

I have a file with embedded subtitles and I am trying to display them along with the picture. The file is an .mkv file with one video, one audio and three subtitle streams. Here's what vlc says about the file:

tales_from_earthsea_codec_info.png

When I play the stream on my linux box using

gst-launch-0.10 filesrc location = /mnt/hgfs/work/test_videos/Tales.from.Earthsea\[h264.dts\]\[niizk\].mkv ! decodebin2 name=dec ! subtitleoverlay name=overlay ! ffmpegcolorspace ! autovideosink  dec. ! overlay.

everything works correctly. However when I try to play that on the i.MX6 board using

gst-launch-0.10 filesrc location = /mnt/sdb1/kur/Tales.from.Earthsea\[h264.dts\]\[niizk\].mkv ! decodebin2 name=dec ! subtitleoverlay name=overlay ! ffmpegcolorspace ! mfw_v4lsink  dec. ! overlay.

it plays the video fine but it doesn't display any subtitles. The output is:

MFW_GST_V4LSINK_PLUGIN 3.0.5 build on Oct 22 2013 15:33:00.

Setting pipeline to PAUSED ...

Pipeline is PREROLLING ...

Aiur: 3.0.5

Core: MKVPARSER_01.04.01  build on Dec 10 2012 15:43:34

  mime: video/x-matroska ; video/webm

  file: /usr/lib/imx-mm/parser/lib_mkv_parser_arm11_elinux.so

Content Info:

  URI:

       file:///mnt/sdb1/kur/Tales.from.Earthsea[h264.dts][niizk].mkv

  Idx File:

       /root/.aiur/.mnt.sdb1.kur.Tales.from.Earthsea[h264.dts][niizk].mkv.aidx

  Seekable  : Yes

  Size(byte): 2100598489

 

 

Movie Info:

  Seekable  : Yes

  Live      : No

  Duration  : 1:55:29.856000000

  ReadMode  : Track

  Track     : 5

 

 

Track 00 [video_000000] Enabled

  Duration: 1:55:29.856000000

  Language: und

  Mime:

       video/x-h264, parsed=(boolean)true, width=(int)656, height=(int)432, framerate=(

       fraction)23/1, codec_data=(buffer)0000000167640033ac34e380a437a1000003007d000017

       6a8f18318e800000000168eebce5531cc305d2628d13080214868783a1c0d04e12142c0ac0da02fe

       10042ad35e9e850b748c778a1410088b172105449ca3050e204448b20a4d8a081827090809848541

       dc4290a43164215a201900cae8340f81e86f03300b6017002ac05981d61a07802a8400a902087404

       700bc010506e036404b811805902e07203e0087ff85b

vpudec versions

  plugin: 3.0.5

  wrapper: 1.0.28(VPUWRAPPER_ARM_LINUX Build on Oct 22 2013 15:28:56)

  vpulib: 5.4.10

  firmware: 2.1.8.34588

Track 01 [audio_000000] Enabled

  Duration: 1:55:29.856000000

  Language: jpn

  Mime:

       audio/x-dts, channels=(int)6, rate=(int)48000, bitrate=(int)0

Track 02 [subtitle]: Disabled

  Codec: 6, SubCodec: 0

Track 03 [subtitle]: Disabled

  Codec: 7, SubCodec: 0

Track 04 [subtitle]: Disabled

  Codec: 7, SubCodec: 0

>>V4L_SINK: Actually buffer status:

  hardware buffer : 21

  software buffer : 0

Pipeline is PREROLLED ...

Setting pipeline to PLAYING ...

full screen size:800x480

[V4L Update Display]: left=0, top=0, width=800, height=480

New clock: GstSystemClock

As you can see aiurdemux reports that the subtitle tracks are disabled. Do you have any Idea how I can make this work?

Please tell me if you need some additional info.

Outcomes