AnsweredAssumed Answered

IMX53 smd camera.  ERROR:  v4l2 capture: slave not found!

Question asked by Janis Coders on Nov 27, 2012
Latest reply on Jan 2, 2013 by Janis Coders
Branched to a new discussion

Hi, I am trying to compile and set up Linux on IMX53 smd (SABRE) platform, and then all the things I learn, I try to put on our custom platform which is kind of a hybrid created from smd and QSB

The problem is that I can't get working camera on smd. I am not using ltbi, because I have Ubuntu 12.04, don't have place for Virtual machine and want to do everything myself.

Kernel is downloaded from Freescale/linux-imx at patches-imx-2.6.35_11.09.01 · GitHub. Filesystem is Ubuntu 12.04 armhf.

First I tried USB camera, which creates /dev/video0 and can record video just fine. Then I tried to get running the included camera.

As I understand - these modules must be installed: modprobe ov5642_camera && modprobe mxc_v4l2_capture.

lsmod shows that these modules are loaded with their respective dependencies. But when I try to do anything with the /dev/video0 file it always shows error on dmesg ERROR: v4l2 capture: slave not found!

 

 

Outcomes