AnsweredAssumed Answered

Help: LTIB build failed

Question asked by danix on May 5, 2011
Latest reply on Nov 24, 2014 by Jorge Pereira

Hi folks,

 

I'm trying to install and build LTIB as in the installation guide in the BSP, but I got the following error while building it;

.

.

.

Copying packages to /home/danny/ltib/pkgs

Installation complete, your ltib installation has been placed in
/home/danny/ltib, to complete the installation:

cd /home/danny/ltib
./ltib

danny@danny-beast:~$ cd /home/danny/ltib
danny@danny-beast:~/ltib$ ./ltib
sh: g++: not found
sh: tclsh: not found

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
libstdc++              0             not installed
gcc-c++                2.96          not installed
zlib-devel             0             not installed
rpm                    0             not installed
rpm-build              0             not installed
ncurses-devel          0             not installed
m4                     0             not installed
bison                  0             not installed
patch                  0             not installed
tcl                    0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Started: Thu May  5 18:32:58 2011
Ended:   Thu May  5 18:32:58 2011
Elapsed: 0 seconds


Build Failed

Exiting on error or interrupt
danny@danny-beast:~/ltib$

 

what should I do, then...

 

PS: I'm new to LTIB and even to Linux, so forgive me if that is a stupid question

Outcomes