Help: LTIB build failed

cancel
Showing results for 
Search instead for 
Did you mean: 

Help: LTIB build failed

Jump to solution
11,441 Views
danix
Contributor III

Hi folks,

 

I'm trying to install and build LTIB as in the installation guide in the BSP, but I got the following error while building it;

.

.

.

Copying packages to /home/danny/ltib/pkgs

Installation complete, your ltib installation has been placed in
/home/danny/ltib, to complete the installation:

cd /home/danny/ltib
./ltib

danny@danny-beast:~$ cd /home/danny/ltib
danny@danny-beast:~/ltib$ ./ltib
sh: g++: not found
sh: tclsh: not found

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
libstdc++              0             not installed
gcc-c++                2.96          not installed
zlib-devel             0             not installed
rpm                    0             not installed
rpm-build              0             not installed
ncurses-devel          0             not installed
m4                     0             not installed
bison                  0             not installed
patch                  0             not installed
tcl                    0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Started: Thu May  5 18:32:58 2011
Ended:   Thu May  5 18:32:58 2011
Elapsed: 0 seconds


Build Failed

Exiting on error or interrupt
danny@danny-beast:~/ltib$

 

what should I do, then...

 

PS: I'm new to LTIB and even to Linux, so forgive me if that is a stupid question

Tags (1)
1 Solution
1,650 Views
MarianoGoluboff
Contributor III

Hi Daniel,

I haven't seen these problems before, and I've used ltib on Ubuntu 9.04, so it can be done. What I would suggest at this point is to completely remove ltib (and the /opt/freescale directory), then re-install after making sure that your Ubuntu box is setup per the instructions in my second post on this thread.

 

If you don't want to run that script and instead manually figure out what to do, you should follow the steps here:

http://www.imxdev.org/wiki/index.php?title=ALL_Boards_ltib_config_ubuntu

 

After you have that setup, then install and re-run LTIB.

 

If you're still getting this problem, then go to freescale.com, login to "My Freescale", and click on Enter a Service Request to get an apps engineer from Freescale to help you out.

 

Mariano

View solution in original post

0 Kudos
31 Replies
1,107 Views
AaronLinsdau
Contributor I

Did you ever get a resolution to this?  I'm trying to install LTIB but it can't find any of the packages, yet they're in the LTIB folder structure.

0 Kudos
1,107 Views
KursadOney
NXP Employee
NXP Employee

Try this patch if you haven't already:

diff --git a/bin/Ltibutils.pm b/bin/Ltibutils.pm
index 76e2506..7464795 100755
--- a/bin/Ltibutils.pm
+++ b/bin/Ltibutils.pm
@@ -580,7 +580,9 @@ TXT
                          unless  -f '/usr/share/texmf/tex/texinfo/texinfo.tex';
                         `makeinfo --version 2>/dev/null`;
                     },
-    zlib         => sub { my @f = (glob('/usr/lib/i386-linux-gnu/libz.so*'),
+    zlib         => sub { my @f = (glob('/usr/lib/libz.so*'),
+                                   glob('/lib/libz.so*'),
+                                   glob('/usr/lib/i386-linux-gnu/libz.so*'),
                                    glob('/lib/i386-linux-gnu/libz.so*'),
                                    glob('/lib64/libz.so*')  ); @f > 1 ? 1 : 0 },
     'zlib-devel' => sub { -f '/usr/include/zlib.h' },

Make sure libz.so points to the correct one in your system.

1,107 Views
LeonardoSandova
Specialist I

For those using ubuntu 12.04, I have created a simple script with do all the necessary patching. Please refer to

patch-ltib-ubuntu12.04.sh

In fact, you do not even need to download, just to to the page, copy  the download link and 'curl/bash' it:

$ curl -L https://community.freescale.com/servlet/JiveServlet/downloadBody/<latest version>/patch-ltib-ubuntu12.04.sh | bash

I hope it works.

1,107 Views
mohamedkalilull
Contributor III

Hi,

After applying this patch also i am getting error,

:

:

:

RPM build errors:

    Bad exit status from /home/kalil/ALL_LTIBS/new/ltib/tmp/rpm-tmp.26750 (%build)

Build time for u-boot: 17 seconds

Failed building u-boot

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Wed Jan  2 10:54:05 2013

Ended:   Wed Jan  2 10:55:15 2013

Elapsed: 70 seconds

These packages failed to build:

u-boot

Build Failed

Exiting on error or interrupt




0 Kudos
1,107 Views
LeonardoSandova
Specialist I

You have chosen the correct board for U-boot.

Could  you please paste the whole U-boot compilation log when you select a board for u-boot?

Also please try the following:

$ ./ltib -C # meaning to continue even if errors are present

and try to compile just the u-boot package with the following commands

$ ./ltib -m prep -p u-boot

$ ./ltib -m scbuild -p u-boot

0 Kudos
1,107 Views
mohamedkalilull
Contributor III

I tried ./ltib -C, and ./ltib -m prep -p u-boot,

it shows Error

**

Started: Fri Jan  4 16:56:50 2013

Ended:   Fri Jan  4 17:00:57 2013

Elapsed: 247 seconds

These packages failed to build:

u-boot kernel-3.0.35 imx-lib imx-test 

Build Failed

***

and i attached log files


1,107 Views
LeonardoSandova
Specialist I

Hi Mohamed,

for some reason, the u-boot source code lacks the configuration file for your board, which is pretty strange. Let's try to build u-boot without using ltib. Please try the following under

$ rm -rf rpm/BUILD/u-boot-2009.08

$./ltib -m prep -p u-boot

$ cd rpm/BUILD/u-boot-2009.08

$ make ARCH=arm CROSS_COMPILE=/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-none-linux-gnueabi- mx6q_sabresd_config

Configuring for mx6q_sabresd board...

this last step is failing, according to your log, but try it please. Of course, change the CROSS_COMPILE value according to your setup.  If it fails,  for some reason you dont have the following files

$ find -name 'mx6q_sabresd*'

./board/freescale/mx6q_sabresd

./board/freescale/mx6q_sabresd/mx6q_sabresd.c

./board/freescale/mx6q_sabresd/mx6q_sabresd.o

./include/configs/mx6q_sabresd_mfg.h

./include/configs/mx6q_sabresd_android.h

./include/configs/mx6q_sabresd.h

./include/configs/mx6q_sabresd_iram.h

In case the above make command succeeded, type the same command without the mx6q_sabresd_config parameter; the u-boot.bin should be created.

Leo

0 Kudos
1,108 Views
mohamedkalilull
Contributor III

Hi,

  

     I tried with command "./ltib -m prep -p u-boot" for preparing u-boot files, but it is failing at "Applying ENGR00081147 Support i.MX35 3stack board"

and showing like.

*

* You have some suspicious patch lines:

*

* In board/freescale/mx35_3stack/lowlevel_init.S

* indent SP followed by a TAB (line 381)

board/freescale/mx35_3stack/lowlevel_init.S:381:       mov r3, #0xDA

* indent SP followed by a TAB (line 400)

board/freescale/mx35_3stack/lowlevel_init.S:400:       str r3, [r1, #0x100]

+ exit 0

Build time for u-boot: 15 seconds

***********

most of the files not created in "u-boot.2009.08/board/freescale/" directory, with same source code and same command i installed in other system (not ubuntu 12.04) it is working, i attached both logs with this.

0 Kudos
1,108 Views
LeonardoSandova
Specialist I

Hi Mohamed,

Nice to heard that it worked in another Ubuntu machine. Did you know which was the root cause of the original problem?

In the other hand, the log you sent does not show an error, the patching tool is just complaining on some of the input patches but patching is done (you can think those as warnings)

Leo

0 Kudos
1,108 Views
LeonardoSandova
Specialist I

Hi Mohamed, the only thing that come to my mind is to double check the option 'Choose your board for u-boot' you selected on the ltib configuration menu.

0 Kudos
1,108 Views
mohamedkalilull
Contributor III

I selected "mx6q_sabresd" under the option 'choose your board for u-boot" in ltib configuration menu.

...

If i select "Don't build the bootloader" under the option 'Choose your bootloader for U-Boot' following error is coming.

***

*** Can't find default configuration "arch/arm/configs/imx6_defconfig"!

***

make[1]: *** [imx6_defconfig] Error 1

make: *** [imx6_defconfig] Error 2

error: Bad exit status from /home/kalil/ALL_LTIBS/new/ltib/tmp/rpm-tmp.1373 (%build)

RPM build errors:

    Bad exit status from /home/kalil/ALL_LTIBS/new/ltib/tmp/rpm-tmp.1373 (%build)

Build time for kernel-3.0.35: 203 seconds

Failed building kernel-3.0.35

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Thu Jan  3 15:02:56 2013

Ended:   Thu Jan  3 15:06:23 2013

Elapsed: 207 seconds

These packages failed to build:

kernel-3.0.35

Build Failed

Exiting on error or interrupt

****

the host_config.log also pasted below:

Updating lpp from local packages

Processing platform: Host support packages

============================================

using /home/kalil/ALL_LTIBS/new/ltib/config/platform/host/ltib.preconfig

Processing: fake-provides

===========================

Processing: mkspooflinks

==========================

Processing: distcc

====================

Processing: ccache

====================

Processing: bison

===================

Processing: flex

==================

Processing: texinfo

=====================

Processing: autoconf

======================

Processing: libtool

=====================

Processing: lkc

=================

Processing: wget

==================

Processing: uclinux-cksum

===========================

Processing: genext2fs

=======================

Processing: genromfs

======================

Processing: gen_init_cpio

===========================

Processing: u-boot-tools

==========================

Processing: mtd-utils

=======================

Processing: pkgconfig

=======================

Processing: dtc

=================

Processing: cramfs

====================

Processing: unifdef

=====================

Processing: sparse

====================

Processing: git

=================

Processing: tunctl

====================

Processing: mux_server

========================

Processing: elftosb

=====================

Processing: ubuntu_arm_lib

============================



0 Kudos
1,108 Views
KrishnaPavan
Contributor II

Hi,

// ltib cannot be run because one or more of the host packages missing //

//when I go to install zlib package, it says that "Unable to locate package zlib".//

zlib package can be installed from the Software Sources/Synaptics.

If you are using proxy, then probably you should check that preferences section and authenticate it!

Regards :: Krishna Pavan

0 Kudos
1,114 Views
andrew_questps
Contributor III

The errors are related to ltib/bin/Ltibutils.pm.

On my x64 VM with Ubuntu 11.04 I had to add the following line (it was slightly different for an x86 VM):

glob('/lib/x86_64-linux-gnu/libz.so*'),

on about line 583 where the "zlib => sub" line is in order for ltib to find the library.

1,114 Views
raimundszabo
Contributor II

My fix is glob('/lib/i386-linux-gnu/libz.so*') because the install path on 32 bit Ubuntu 12.04 is this.

1,113 Views
SyedRafiulHussa
Contributor II

Hi,

I am also getting same error:

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
zlib                   0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Exiting on error or interrupt

I also tried to install zlib package. However, when I go to install zlib package, it says that "Unable to locate package zlib". I've checked related previous posts of this group. Sadly, I've found no specific solution for it. Currently, at this point I got badly stuck with this problem. I am eagerly looking forward for your help.

Thanks.

1,113 Views
AdCmo
Contributor III

Daiane,

 

That did not help :(

One poster mentioned that they were able to install zlib, buyt they never mentioned how

or from what package.

 

Even when running a command to list the installed packages I get an interrupt error.

 

i.e.

 

./ltib -m listpkgs
Please specify the preconfig to list, or configure your ltib
traceback:
 main::get_key_list:101
  main::listpkgs:88
   main::f_listpkgs:1206
    main:535

Exiting on error or interrupt

 

Maybe something else going on?

 

thanks,

Ad.

0 Kudos
1,113 Views
daiane_angolini
NXP Employee
NXP Employee
0 Kudos
1,113 Views
AdCmo
Contributor III

Krishna,

 

Yes, I installed all zlib1g* packages i.e.

zlib1g, zlib1g-dbg, zlib1g-dev and libghc-zlib-dev.

I cannot find zlib-devel with aptitude, will this be an issue?

Thanks,
Ad.
-----------------------------------------------

0 Kudos
1,113 Views
KrishnaPavan
Contributor II

Hi Ad,

 

Have you installed all the packages related to zlib.

zlib1g-dbg,zlib1g-dev,zlib1g,etc...

 

Regards  ::: krishna pavan

0 Kudos
1,113 Views
AdCmo
Contributor III

I installed LTIB to /opt/freescale on Ubuntu 11.10 and I am getting a similar error though I know I installed zlib.
This is the error I am getting:

 

ltib cannot be run because one or more of the host packages needed to run it
are either missing or out of date or not in ltib's standard path.  Please
install/upgrade these packages on your host.  If you have your own utilities
in non-standard paths, please add an entry into the .ltibrc file for example:

%path_std
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/my/own/exes

Package                Minimum ver   Installed info
-------                -----------   ---------------
zlib                   0             not installed

Died at ./ltib line 1397.
traceback:
 main::host_checks:1397
  main:542


Exiting on error or interrupt

When i try to reinstall "zlib1g-dev" it says I already have the newest version.

I am using ltib 9.1.1 ($Revision: 1.445.6.1 $)

Anything else I am missing?

 

Thanks,

Ad.



Mariano Goluboff said:

Hi Daniel,

I haven't seen these problems before, and I've used ltib on Ubuntu 9.04, so it can be done. What I would suggest at this point is to completely remove ltib (and the /opt/freescale directory), then re-install after making sure that your Ubuntu box is setup per the instructions in my second post on this thread.

 

If you don't want to run that script and instead manually figure out what to do, you should follow the steps here:

http://www.imxdev.org/wiki/index.php?title=ALL_Boards_ltib_config_u...

 

After you have that setup, then install and re-run LTIB.

 

If you're still getting this problem, then go to freescale.com, login to "My Freescale", and click on Enter a Service Request to get an apps engineer from Freescale to help you out.

 

Mariano

0 Kudos