Debugging MIMXRT1020 with Segger Ozone

cancel
Showing results for 
Search instead for 
Did you mean: 

Debugging MIMXRT1020 with Segger Ozone

Jump to solution
604 Views
alphafred
Contributor I

Hi

I am trying to get debugging working for my MIMXRT1021.

I am using the MIMXRT1020-EVK with a Segger JLINK. Downloading my image works fine and it is running as expected however when I try to debug using Segger Ozone I receive the following issues:

Screenshot_2020-03-10_17-40-22.png

Screenshot_2020-03-10_17-41-12.png

I know that debugging is working because my JLink etc. is working perfectly fine with MCUXpresso IDE.

However I would like to get it working with Ozone :-).

Am I missing some additional configuration I need to do in order to get it working? I tried to figure out if MCUXpresso IDE is setting something behind the scenes already but to no avail. Maybe someone else has tried with Ozone and ran into the same issues.

BR

Philipp

Labels (1)
0 Kudos
1 Solution
500 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi alphafred ,

  Normally, we use the IDE associated with the JLINK debugger to debug the project code.

  If you already make the MCUXPresso IDE and the JLINK debug works, and just the Ozone can't work, it should be related to the ozone configuration.

  As you know, ozone is the Segger product, so the Segger engineer will be more familiar with it.

  Could you please contact with the Segger engineer, they will help you with the detail Ozone software configuration.

https://www.segger.com/support/technical-support/ 

  Please create your OZONE question in the Segger side, and let the Segger expert helps you!

If you need any help from my side, just let me know.

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

View solution in original post

0 Kudos
3 Replies
500 Views
alphafred
Contributor I

@Kerry Zhou

Thank you for referencing me to the Segger support. Could have thought of that myself :-).

 

They could help me solving my issue.

For anyone running into the same problem I did, here is the solution. Since MIMXRT1020 is using a ROM bootloader this information has to be given to JLink. Each Ozone project is actually a .jlink file containing all the hooks etc. that you can use in order to control the debugger.

This page of the SEGGER wiki contains the answer to the problem - "the functions AfterTargetDownload() and AfterTargetReset() empty (but not commented out!)".

BR

Philipp

0 Kudos
500 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hello alphafred,

  Thanks so much for your sharing! Perfect!

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
501 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi alphafred ,

  Normally, we use the IDE associated with the JLINK debugger to debug the project code.

  If you already make the MCUXPresso IDE and the JLINK debug works, and just the Ozone can't work, it should be related to the ozone configuration.

  As you know, ozone is the Segger product, so the Segger engineer will be more familiar with it.

  Could you please contact with the Segger engineer, they will help you with the detail Ozone software configuration.

https://www.segger.com/support/technical-support/ 

  Please create your OZONE question in the Segger side, and let the Segger expert helps you!

If you need any help from my side, just let me know.

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

View solution in original post

0 Kudos