yocto build failing for sumo due to broken dependencies

cancel
Showing results for 
Search instead for 
Did you mean: 

yocto build failing for sumo due to broken dependencies

461 Views
Contributor I

I am attempting to build a sumo yocto image for my imx8mqevk. When I invoke 'bitbake fsl-image-qt5-validation-imx' I get the following error:

Error:
 Problem: package packagegroup-fsl-tools-testapps-1.0-r0.imx8mqevk requires cryptodev-module, but none of the providers can be installed
  - package cryptodev-module-1.9-r0.imx8mqevk requires kernel-module-cryptodev-4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbeafb80c, but none of the providers can be installed
  - conflicting requests
  - nothing provides kernel-4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbeafb80c needed by kernel-module-cryptodev-4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbeafb80c-1.9-r0.imx8mqevk

now, it is correct that nothing is providing "kernel-4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbeafb80c" BUT the kernel-base package is providing "kernel-4.14.98-imx_4.14.98_2.0.0_ga+g5d6cbea"

Why are hash parts of the version truncated for some packages? I'm pretty sure they should be the same, but which is correct? Why did this happen and how can I fix it?

This happened in a ubuntu 18.04 docker container, so this should be very reproduceable. The only variations from the stock ubuntu 18.04 container were installing the necessary package for the yocto build and fixing the locale settings (making it en_US.UTF-8).

From there I just ran

'repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-sumo -m imx-4.14.98-2.0.0_ga.xml'

'MACHINE=imx8mqevk DISTRO=fsl-imx-wayland source ./fsl-setup-release.sh -b bld-build'

and finally

'bitbake fsl-image-qt5-validation-imx'

0 Kudos
4 Replies

160 Views
NXP TechSupport
NXP TechSupport

Hi Aaron,

  ubuntu 16.04 LTS is recommended by us,  I will have to prepare cross compile environment to test it, which will take me some time. If your project is in a hurry, please change to Ubuntu 16.04!

Have a nice day!

BR,

Weidong

0 Kudos

160 Views
Contributor I

This started working yesterday. I don't know what changed. I did a repo sync and there were a couple of changes pulled down, so maybe that was it, but everything works now.

0 Kudos

160 Views
NXP TechSupport
NXP TechSupport

Hello Aaron Solochek,

     The document has been released on : Compiling L4.14.98-2.0.0 BSP on Ubuntu 18.04 LTS 

I spent 4 days to compile the BSP on ubuntu 18.04 platform, below is my steps, for you reference:

--------------------

1. Installation of Ubuntu 18.04

pastedImage_1.png

2.Update software

pastedImage_2.png

3. Installing software package for compiling BSP

# sudo apt-get install flex

# sudo apt-get install bison

# sudo apt-get install gperf

# sudo apt-get install build-essential

# sudo apt-get install zlib1g-dev

# sudo apt-get install lib32ncurses5-dev

# sudo apt-get install x11proto-core-dev

# sudo apt-get install libx11-dev

# sudo apt-get install lib32z1-dev

# sudo apt-get install libgl1-mesa-dev

# sudo apt-get install tofrodos

# sudo apt-get install python-markdown

# sudo apt-get install libxml2-utils

# sudo apt-get install xsltproc         

# sudo apt-get install uuid-dev:i386 liblzo2-dev:i386

# sudo apt-get install gcc-multilib g++-multilib

# sudo apt-get install subversion

# sudo apt-get install openssh-server openssh-client

# sudo apt-get install uuid uuid-dev

# sudo apt-get install zlib1g-dev liblz-dev

# sudo apt-get install liblzo2-2 liblzo2-dev

# sudo apt-get install lzop

# sudo apt-get install git-core curl

# sudo apt-get install u-boot-tools

# sudo apt-get install mtd-utils

# sudo apt-get install android-tools-fsutils

# sudo apt-get install openjdk-8-jdk

# sudo apt-get install device-tree-compiler

# sudo apt-get install aptitude

# sudo aptitude install libcurl4-openssl-dev nss-updatedb

 

From i.MX_Yocto_Project_User's_Guide.pdf:

# sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib \

build-essential chrpath socat libsdl1.2-dev

 

  1. Downloading Yocto BSP according to steps in MX_Yocto_Project_User's_Guide.pdf

5Compiling L4.14.98-2.0.0 BSP

# cd ~/imx-yocto-bsp

# DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-wayland

# bitbake fsl-image-qt5-validation-imx

In the process of compilation, there have been many "fetch errors", which are caused by disconnection or timeout of network connection.

We just need to run the bitmake command again in the build Wayland subdirectory to continue the compilation.

# bitbake fsl-image-qt5-validation-imx

         Fetching errors below were what I encountered:

pastedImage_3.png

pastedImage_4.png

pastedImage_7.png

         The following picture is to re-run “bitbake fsl-image-qt5-validation-imx” after fetch errors occurred.

pastedImage_8.png

         In order to improve the speed of compilation , I re-configured vmware player, assigning 6 CPU cores for Ubuntu.

pastedImage_11.png

         Compilation is a long and arduous process. It took 4 days to compile normally with error handling. Finally, the compilation was completed.

pastedImage_12.png

So it means there is no any problem to compile L4.14.98-2.0.0 fsl-imx-waylan image on ubuntu 18.04 platform.

Have a nice day!

BR,

Weidong

0 Kudos

160 Views
Contributor I

Thank you for the reply. I should have mentioned in the original post that I also tried this on 16.04 and it failed, although I did not dig into reasons for the failure as thoroughly.

Also, since posting the question I have tested on an actual Ubuntu 18.04 machine, and the build works there. The issue looks to specifically be in the docker environment. 

I will verify that the same issue occurs on 16.04 in docker and post the dockerfile.

0 Kudos