video decode problem

cancel
Showing results for 
Search instead for 
Did you mean: 

video decode problem

422 Views
hiper
Contributor I

I am creating simple playback pipeline.

I noticed video decoding problem when playback pipeline is constructed using Freescale's mfw_vpudecoder element on IMX53QSB evm with root file system created by LTIB tool.

When playing some videos, green screen effect with some random color noise is observed.

Example pipelines are as follows:

gst-launch playbin2 uri=file:///home/user/green2.mp4

gst-launch filesrc location=/home/user/green2.mp4 typefind=true ! aiurdemux name=dmx dmx.video_00 ! mfw_vpudecoder ! mfw_isink

Problematic media file is attached to the message.

The problem does not exist when Freescale's mfw_vpudecoder element is replaced by software-based decoder ffdec_h264.

Please give me some advise on how to resolve this problem, or, advise how to catch information about such error via GStreamer bus watch. So that I can detect hardware accelerator failure and use software-based ffdec_h264 on such occasions.

Thank you for your time.

Labels (2)
0 Kudos
3 Replies

43 Views
jimmychan
NXP TechSupport
NXP TechSupport

There is MX51/MX53 VPU firmware update to fix H264 mosaic issue.

0 Kudos

43 Views
janiscoders
Contributor III

I am no expert, but sometimes there are some strange bugs regarding these plugins. What I would do to debug it:

1) Try mfw_v4lsink, because I've had some quality issues with mfw_isink

2) Try colorspace converting using mfw_ipucsc, because in different gst-fsl-plugins versions I've had different results for different raw formats (but that was when encoding video).

3) Try different video?

0 Kudos

43 Views
hiper
Contributor I

Dear janiscoders,

thank you for your reply. However I am quite limited in possibilities you mentioned.

1) mfw_isink is mandatory, because for some reason when mfw_v4lsink element is used our OSD function does not work via /dev/fb0;

2) I will try to insert mfw_ipucsc, however I doubt that color conversion will resolve defective decoding problem;

3) I am not in a position to dictate our users what kind of videos they can or can not reproduce with our media player.

As a matter of fact I can not even detect if some media file will result in defective decoding with mfw_vpudecoder.

It would be funny to declare in user's manual a statement like this one: "if you already see green screen defect when reproducing video - then you probably should not play this video at all".

0 Kudos