porting guide errors

Showing results for 
Search instead for 
Did you mean: 

porting guide errors

Contributor V

I am following i.MX Porting Guide , Rev. LF5.10.35_2.0.0, 30 June 2021 (the latest to date)

I can build the whole demo image and the linux-imx kernel just fine for the standard iMX8mp evk

I am attempting to use section 2.1.2  How to build and load Kernel in Yocto Project

I followed the instructions exactly but can not get my custom kernel to build.

I have a modified MACHINE name and I have a slightly modified kernel defconfig that just adds some extra drivers, I renamed "custom_defconfig" and placed it in a modified recipe under my new layer.

i.e. recipes-kernel/linux_imx/files

I have linux-imx_5.10.bbappend with just the following:

SRC_URI_append = "file://custom_defconfig"



I set my custom layer to a high priority (10)

I have no patches ... just added another kernel driver only

I can tell my custom layer is being picked up by using  bitbake-layers show-layers that is ok

when I run bitbake linux-imx it seems to stall at the do_fetch stage.

There is something quite obviously wrong with the documentation as written.

I have tried this several times with several different permutations but nothing works.

I can only conclude it was never tested with the latest release. I can see several of the linux-imx bitbake tasks were changed from what I remember in previously releases, maybe that has something to do with it?

Afer a LOOOONG time in the do_fetch I get this warning:

NOTE: Executing Tasks
WARNING: linux-imx-5.10.35+gitAUTOINC+ef3f2cfc60-r0 do_fetch: Failed to fetch URL git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=lf-5.10.yfile://custom_defconfig, attempting MIRRORS if available

It then tries mirror etc.

I do not know why it is trying fetch custom_defconfig remotely as it is local.






2 Replies

Contributor V

seems I am not the only one having this issue

Re: howto add my kernel defconfig file to yocto - NXP Community

Contributor V

It seems the in-tree kernel recipe  now kind of follows the Qoriq builds and the documentation has not caught up.

I was able to insert a kernel configuration fragment by creating a linux-imx_5.10.bbappend file with the following:

FILESEXTRAPATHS_prepend := "${THISDIR}/files:"

# add custom fragment
SRC_URI += "file://build/custom.cfg"



Note: "${THISDIR}/files:" and SRC_URI += "file://build/custom.cfg" to place fragment at proper directory