libtool: Version mismatch error.

cancel
Showing results for 
Search instead for 
Did you mean: 

libtool: Version mismatch error.

Jump to solution
1,321 Views
john_cheng
Contributor I

make  all-recursive

make[1]: Entering directory `/home/archimage/mx28_evk/ltib/rpm/BUILD/libusb-0.1.8'

Making all in .

make[2]: Entering directory `/home/archimage/mx28_evk/ltib/rpm/BUILD/libusb-0.1.8'

if /bin/bash ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.      -MT usb.lo -MD -MP -MF ".deps/usb.Tpo" \

      -c -o usb.lo `test -f 'usb.c' || echo './'`usb.c; \

    then mv -f ".deps/usb.Tpo" ".deps/usb.Plo"; \

    else rm -f ".deps/usb.Tpo"; exit 1; \

    fi

if /bin/bash ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.      -MT error.lo -MD -MP -MF ".deps/error.Tpo" \

      -c -o error.lo `test -f 'error.c' || echo './'`error.c; \

    then mv -f ".deps/error.Tpo" ".deps/error.Plo"; \

    else rm -f ".deps/error.Tpo"; exit 1; \

    fi

if /bin/bash ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.      -MT descriptors.lo -MD -MP -MF ".deps/descriptors.Tpo" \

      -c -o descriptors.lo `test -f 'descriptors.c' || echo './'`descriptors.c; \

    then mv -f ".deps/descriptors.Tpo" ".deps/descriptors.Plo"; \

    else rm -f ".deps/descriptors.Tpo"; exit 1; \

    fi

if /bin/bash ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.      -MT linux.lo -MD -MP -MF ".deps/linux.Tpo" \

      -c -o linux.lo `test -f 'linux.c' || echo './'`linux.c; \

    then mv -f ".deps/linux.Tpo" ".deps/linux.Plo"; \

    else rm -f ".deps/linux.Tpo"; exit 1; \

    fi

./libtool: line 469: CDPATH: command not found

./libtool: line 469: CDPATH: command not found

./libtool: line 469: CDPATH: command not found

./libtool: line 469: CDPATH: command not found

libtool: Version mismatch error.  This is libtool 2.4.2, but the

libtool: definition of this LT_INIT comes from an older release.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2

libtool: and run autoconf again.

libtool: Version mismatch error.  This is libtool 2.4.2, but the

libtool: definition of this LT_INIT comes from an older release.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2

libtool: and run autoconf again.

libtool: Version mismatch error.  This is libtool 2.4.2, but the

libtool: definition of this LT_INIT comes from an older release.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2

libtool: and run autoconf again.

make[2]: *** [error.lo] Error 1

make[2]: *** Waiting for unfinished jobs....

make[2]: *** [linux.lo] Error 1

libtool: Version mismatch error.  This is libtool 2.4.2, but the

libtool: definition of this LT_INIT comes from an older release.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2

libtool: and run autoconf again.

make[2]: *** [usb.lo] Error 1

make[2]: *** [descriptors.lo] Error 1

make[2]: Leaving directory `/home/archimage/mx28_evk/ltib/rpm/BUILD/libusb-0.1.8'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/archimage/mx28_evk/ltib/rpm/BUILD/libusb-0.1.8'

make: *** [all] Error 2

error: Bad exit status from /home/archimage/mx28_evk/ltib/tmp/rpm-tmp.42346 (%build)

RPM build errors:

    Bad exit status from /home/archimage/mx28_evk/ltib/tmp/rpm-tmp.42346 (%build)

Build time for libusb: 8 seconds

Failed building libusb

f_buildrpms() returned an error, exiting

traceback:

main:572

Started: Tue Sep 30 14:27:03 2014

Ended:   Tue Sep 30 14:28:44 2014

Elapsed: 101 seconds

These packages failed to build:

libusb

Build Failed

Exiting on error or interrupt

/************************************************************************************************************************************************************************/

Dear all,

           when i build the ltib, I ran into the above question, how should I resolve the problem?

host system: ubuntu 10.04LTS

demo board: i.mx28_evk

Best Regards,

Labels (1)
Tags (1)
0 Kudos
1 Solution
177 Views
igorpadykov
NXP TechSupport
NXP TechSupport

try to install i.MX28 ltib on fresh Ubuntu.

~igor

View solution in original post

0 Kudos
7 Replies
177 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi John

had you installed in Ubuntu libtool package

as described on p.4 Setting_Up_LTIB_Host document ?

L2.6.35_1.1.0_LINUX_DOCS

Best regards

igor

0 Kudos
177 Views
john_cheng
Contributor I

Dear  igorpadykov,

         what you say is below, yes, i have installed 1.5 Install Host Packages Needed by LTIB, however i can build mx6q_sabresd's ltib version completely, but when i build mx28_evk version, i get the error of the topic above.

#!/bin/bash

# Install packages needed by LTIB

sudo aptitude -y install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

sudo aptitude -y install libdbus-glib-1-dev liborbit2-dev intltool

sudo aptitude -y install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

sudo aptitude -y install uuid-dev liblzo2-dev

sudo aptitude -y install tcl dpkg

# Packages required for 64-bit Ubuntu

# Do "uname -a" and see if the word "x86_64" shows up.

if uname -a|grep -sq 'x86_64'; then

sudo aptitude -y install ia32-libs libc6-dev-i386 lib32z1

fi

# The following recommended for Linux development.

# They are not required by LTIB.

sudo aptitude -y install gparted emacs22-nox openssh-server

sudo aptitude -y install nfs-common nfs-kernel-server lintian

sudo aptitude -y install git-core git-doc git-email git-gui gitk

sudo aptitude -y install diffstat indent tofrodos fakeroot doxygen uboot-mkimage

sudo aptitude -y install sendmail mailutils meld atftpd sharutils

sudo aptitude -y install manpages-dev manpages-posix

Best Regards,

0 Kudos
177 Views
igorpadykov
NXP TechSupport
NXP TechSupport

after i.MX6 build suggest to run

./ltib -m distclean

and run new fresh ltib build for i.MX28

~igor

0 Kudos
177 Views
john_cheng
Contributor I

but in fact, i have two folder, they are independent project,

<dir>/mx28_evk/ltib

<dir>/mx6q_sabresd/ltib

the two will react upon each other?

0 Kudos
177 Views
john_cheng
Contributor I

Dear igor,

             i use the command.

             ./ltib -m distclean

            ./ltib

             then it appear the same error.

0 Kudos
178 Views
igorpadykov
NXP TechSupport
NXP TechSupport

try to install i.MX28 ltib on fresh Ubuntu.

~igor

View solution in original post

0 Kudos
177 Views
igorpadykov
NXP TechSupport
NXP TechSupport

yes, they can react on each other, ubuntu/ltib may like more newer

libs versions (i.MX6). In general it is not recommended to install different

ltib kernel versions on one Ubuntu.

One can try to install i.MX28 ltib on fresh Ubuntu. You can also look at

https://community.freescale.com/message/314897#314897

~igor

0 Kudos