kernel-devsrc build error in SDK build

cancel
Showing results for 
Search instead for 
Did you mean: 

kernel-devsrc build error in SDK build

1,397 Views
vijayaragavansr
Contributor II

Hi Everyone,

I am using morky release 4.9.1 rootfs,kernel image and uboot buld successfully.was tryihg to added kernel devsrc for module developmet in SDK, but ended up with and below error. please help me in clearing this out.

ERROR: meta-toolchain-1.0-r7 do_populate_sdk: Unable to install packages. Command '/home/vijay/fsl-release-bsp-4.9/bld-x11/tmp/sysroots/i686-linux/usr/bin/smart --log-level=warning --data-dir=/home/vijay/fsl-release-bsp-4.9/bld-x11/tmp/work/cortexa7hf-neon-poky-linux-gnueabi/meta-toolchain/1.0-r7/sdk/image/opt/fsl-imx-x11/4.9.11-1.0.0/sysroots/cortexa7hf-neon-poky-linux-gnueabi/var/lib/smart install -y kernel-devsrc@imx6ulevk packagegroup-core-standalone-sdk-target-dbg@all packagegroup-core-standalone-sdk-target@all kernel-dev@imx6ulevk packagegroup-core-buildessential@all' returned 1:
Loading cache...
Updating cache... ######################################## [100%]

Computing transaction...error: Can't install kernel-devsrc-1.0-r0@imx6ulevk: no package provides /bin/awk


ERROR: meta-toolchain-1.0-r7 do_populate_sdk: Function failed: do_populate_sdk
ERROR: Logfile of failure stored in: /home/vijay/fsl-release-bsp-4.9/bld-x11/tmp/work/cortexa7hf-neon-poky-linux-gnueabi/meta-toolchain/1.0-r7/temp/log.do_populate_sdk.8590
ERROR: Task (/home/vijay/fsl-release-bsp-4.9/sources/poky/meta/recipes-core/meta/meta-toolchain.bb:do_populate_sdk) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3280 tasks of which 3279 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/home/vijay/fsl-release-bsp-4.9/sources/poky/meta/recipes-core/meta/meta-toolchain.bb:do_populate_sdk
Summary: There were 2 WARNING messages shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Note : using yocto build

bitbake meta-toolchain

Thanks

Vijay

6 Replies

607 Views
vijayaragavansr
Contributor II

Hi Everyone,

am struck with SDK build. please any one throw some ideas?

Thanks

Vijay

607 Views
georgefff
Contributor II

Hi Vijayaragavan,

Were you able to fix the SDK generation with kernel-devsrc package?

Thanks in advance!

0 Kudos

607 Views
vijayaragavansr
Contributor II

No

0 Kudos

607 Views
vijayaragavansr
Contributor II

Hi,

Any inputs to resolve this? i think kernel patch(4.9) is required for this. if yes how do to this pathc?

Thanks

Vijay

0 Kudos

607 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Vijay,

I would like to confirm the BSP Release you are using to try to duplicate this issue. Is it the 4.9.11_1.0.0 BSP Release?

I would also like to double check your Host OS. Ubuntu 14.04 is recommended and there are several packages that need to be installed that are listed on the i.MX Yocto Project User’s Guide.

If you are using NXP’s BSP you wouldn’t need any additional patches.

I’ll be looking forward to hearing back from you,

Regards,

0 Kudos

607 Views
vijayaragavansr
Contributor II

Hi gusarambula ,

Thank you for the reply.

I am using 4.9.11_1.0.0 BSP Release and NXP BSP only.

Am using Ubuntu 16.04. Though I use this am able to successfully compile both core-image-minimal and core-image-base successfully.

its only the issue that when I try to add kernel-devsrc into part of SDK/ToolChain. So what is the change required here?As i understand that bitbake is looking for awk in host PC or the compiled target rootfs so where and in which file i have to change from /usr/bin/awk to /bin/awk or vice versa. or is there a patch/update for this from NXP?

 

Thanks

Vijay

0 Kudos