imx6ul adv7181 problem

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

imx6ul adv7181 problem

1,157 Views
lemficb
Contributor II

Hi all,

    I have troubled with my imx6ul camera for some days. I used adv7181 on my imx6ul custom board,  now ,I have already moved the 7181's driver to my 4.1.15 BSP. The driver is refer to the adv7180.c , and now , the device has been already registerd, the signal of clock and  adv7181's 8 output data signals are all right . But when I use '/unit_tests/mx6s_v4l2_capture.out -m 0 -d /dev/video0' to test my driver, there is a error log just like this

  'Found v4l2 capture device /dev/video0.
  VIDIOC_S_PARM failed'

I am not sure whether my test method is wrong or my driver have some other  problems. Someone could  give me some advices?

With my best regards

Jun

Tags (1)
0 Kudos
Reply
4 Replies

827 Views
igorpadykov
NXP Employee
NXP Employee

Hi  龚军 龚

could you try attached patch.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
Reply

827 Views
lemficb
Contributor II

Hi igorpadykov,

           I have already put your patch to my kernel. But when I build the adv7180 driver , I found that  there is no definition of "enum_framesizes",''enum_frameintervals"  and "g_std"  in the "static struct v4l2_subdev_video_ops " and "static struct v4l2_subdev_core_ops " struct. So I remove these three member variable, and the driver can be complied by.

          I used the  file "mx6s_v4l2_capture.c" to test ,and the camera have some problem. I don't know whether  the driver i removed may lead to this problem. I   can detect the adv7181 device and  the adv7181's output data also have signal.

Here is the test result.

 

  root@imx6ulevk:~# ./camera_test -ow 320 -oh 240 -m 1 -d /dev/video0
Found v4l2 capture device /dev/viadv7180_s_parm: enter adv7180_s_parm
deo0.
pixelformat (output by camera): UYVY
get capture mode 1 framesize failed

Best regards

Jun

0 Kudos
Reply

827 Views
igorpadykov
NXP Employee
NXP Employee

Hi Jun

seems these are standard V4L2 VIDIOC_ENUM_xx ioctl structures.

Best regards
igor

0 Kudos
Reply

827 Views
lemficb
Contributor II

igorpadykov, thanks your quick reply .

0 Kudos
Reply