iMX6Q sata mount automatically problem

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6Q sata mount automatically problem

Jump to solution
445 Views
jasonhsu
Contributor III

Hi Community,

I mount sata as below way, but it cannot mount automatically:

add this line

/devices/platform/ahci /mnt/ssd ntfs defaults voldmanaged=sdcard:auto

in device/fsl/sabreauto_6q/fstab.freescale.

after system bootup, in dev/block folder, it can find following:

sda

sda1

sda2

sda5

but there is nothing in /mnt/ssd.

However, when I try to mount manually, it will be mounted successfully.

root@sabreauto_6q:/ # mount -t ntfs /dev/block/sda1 /mnt/ssd/

NTFS volume version 3.1.

Could you give me some advices how to make it auto mount successfully after boot?

many thxs....:smileyhappy:

Labels (5)
Tags (2)
0 Kudos
1 Solution
60 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi jianhua

I think first parameter is fstab should be /dev/sda1 or

/dev/block/sda1 according to

Fstab - Community Help Wiki

Best regards

igor

View solution in original post

0 Kudos
2 Replies
61 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi jianhua

I think first parameter is fstab should be /dev/sda1 or

/dev/block/sda1 according to

Fstab - Community Help Wiki

Best regards

igor

View solution in original post

0 Kudos
60 Views
jasonhsu
Contributor III

Hi igor

thx for your reply

it is fixed according to your advice.

:smileywink:

0 Kudos