how to enable hdmi display in uboot in imx6qp

cancel
Showing results for 
Search instead for 
Did you mean: 

how to enable hdmi display in uboot in imx6qp

222 Views
Contributor III

Hi guys,

I am testing hdmi display in uboot, but no display in uboot and it is sucessful to enable hdmi display in kernel.

I have modified display order from lvds to hdmi which first disable lvds and enable "do_enable_hdmi" that sets the initialization of hdmi(such as imx_enable_hdmi_phy()).

Is there any modification to enable hdmi display instead of lvds in uboot? I'd like to show uboot logo in hdmi monitor.

Labels (3)
0 Kudos
8 Replies

60 Views
Contributor III

Hi Joan,

I have a question about your patches included before. I am going to enable hdmi, but in setup_hdmi, your patch sets up

iomux of hdmi_i2c as dedicated ones in i2c2 that results errors of pmic i2c read/write error using same i2c2 bus line.

What do you think about that? 

0 Kudos

60 Views
Contributor III

Hi Joan,

Thank you for answer.

I will check your patch.

By the way, I'd like to display screen to hdmi in uboot as well as in kernel that kernel is ok to display the screen to hdmi.

I think Imx6qp bsp have responsible for displaying screen to hdmi both in uboot and in kernel.

When I have modified sequences for display in uboot that in defaut first mode is lvds from lvds to hdmi.

and I modified to call "setup_display" func and "enable_hdmi_display" func and then, 

after hdmi phy reset is on, the device is stuck in uboot and doesnt go to kernel. So, I think imx6 bsp has a problem to change hdmi display mode in uboot.

Could you please raise my problem to bsp team for imx6? 

Thanks,

0 Kudos

60 Views
Contributor III

Hi Joan,

Thank you for response.

kernel version is 4.14.98 and

U-Boot 2018.03(Jul 14 2020 - 14:42:06 +0900)

but actually, hdmi display in uboot doesn't work. Could you please check this?

Below is my modification:

1. board/freescale/mx6sabresd.c(I have modified this one to my custom file)

: changed display table order from -> 1. lvds 2. hdmi to 1.hdmi

: changed dtsi -> mxcfb1 -> ldb to hdmi and &ldb status = "disabled"

Best Regards,

0 Kudos

60 Views
NXP TechSupport
NXP TechSupport

maybe you can refer to the document, it's useful, but this is for old bsp, customer needs to porting to new bsp

https://community.nxp.com/docs/DOC-98109 

0 Kudos

60 Views
Contributor III

Hi guys,

My point is I'd like to display Logo splash image in uboot in hdmi display, but I have changed display order to hdmi,

only shown up black screen in uboot.

Could you please guide me to modify to enable the splash screen in uboot with hdmi display?

Thanks

0 Kudos

60 Views
NXP TechSupport
NXP TechSupport

what bsp version do you use? as I known the latest uboot supports this already

0 Kudos

60 Views
Contributor III

Hi Joan,

Yes, i did.

I have tried the above command, so hdmi display is okay in kernel. My problem is no hdmi display in uboot.

Do you mean if i use the above bootargs, hdmi display is possible in uboot also? 

0 Kudos

60 Views
NXP TechSupport
NXP TechSupport

did you use linux? you can try to use the command in the uboot as below:

For i.MX 6 boards:
U-Boot > setenv mmcargs 'setenv bootargs ${bootargs} root=/dev/mmcblk3p2 rootwait
rw video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24'

0 Kudos