how to boot image from ram directly using mfgtool i.e. usb boot

cancel
Showing results for 
Search instead for 
Did you mean: 

how to boot image from ram directly using mfgtool i.e. usb boot

1,083 Views
ankitkumarsingh
Contributor II

i want to do usb boot test in the imx6ul board for that i am using mfgtool to dump the image directly to ram via usb _otg . following the code change i made in ulc2.xml file of mfgtool.

<LIST name="TestRAM" desc="Choose as media">
<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx6q%plus%%board%_sd.imx" ifdev="MX6Q">Loading U-boot</CMD>
<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx6dl%board%_sd.imx" ifdev="MX6D">Loading U-boot</CMD>
<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx6sx%board%_emmc.imx" ifdev="MX6SX">Loading U-boot</CMD>
<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-imx7d%7duboot%_sd.imx" ifdev="MX7D">Loading U-boot</CMD>
<CMD state="BootStrap" type="boot" body="BootStrap" file ="firmware/u-boot-sd-2016.03-r0.imx" ifdev="MX6UL">Loading U-boot</CMD>

<CMD state="BootStrap" type="load" file="firmware/zImage" address="0x12000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6Q MX6D">Loading Kernel.</CMD>
<CMD state="BootStrap" type="load" file="firmware/zImage--4.1.15-r0-imx6ulevk-20170124103725.bin" address="0x80800000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6SL MX6SX MX7D MX6UL">Loading Kernel.</CMD>

<CMD state="BootStrap" type="load" file="firmware/%initramfs%" address="0x12C00000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6Q MX6D">Loading Initramfs.</CMD>
<CMD state="BootStrap" type="load" file="firmware/%initramfs%" address="0x83800000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6SL MX6SX MX7D MX6UL">Loading Initramfs.</CMD>

<CMD state="BootStrap" type="load" file="firmware/zImage-imx6q%plus%-%board%%ldo%.dtb" address="0x18000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6Q">Loading device tree.</CMD>
<CMD state="BootStrap" type="load" file="firmware/zImage-imx6dl-%board%%ldo%.dtb" address="0x18000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6D">Loading device tree.</CMD>
<CMD state="BootStrap" type="load" file="firmware/zImage-imx6sx-%sxdtb%-emmc.dtb" address="0x83000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6SX">Loading device tree.</CMD>
<CMD state="BootStrap" type="load" file="firmware/zImage-imx7d-%7ddtb%.dtb" address="0x83000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX7D">Loading device tree.</CMD>
<CMD state="BootStrap" type="load" file="firmware/zImage--4.1.15-r0-imx6ul-14x14-evk-20170124103725.dtb" address="0x83000000"
loadSection="OTH" setSection="OTH" HasFlashHeader="FALSE" ifdev="MX6UL">Loading device tree.</CMD>

<CMD state="BootStrap" type="jump" > Jumping to OS image. </CMD>

 

After making change i saw the log in serialport terminal ,linux is not booted completly i am not getting the root login terminal.

 

i tried with imx_usb_loader in linux but i want to do using mfgtool in windows.

 

Please provide some guidance over it.

Original Attachment has been moved to: log_from_mfgtool.txt.zip

Labels (1)
0 Kudos
5 Replies

140 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi ANKIT

for mfg tools uboot please check settings #define CONFIG_MFG_ENV_SETTINGS

in uboot/include/configs/mx6ul_14x14_evk.h

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

140 Views
ankitkumarsingh
Contributor II

Hi Igor,

I also want to put root file system to ram .

Is there any particular location in ram to put rootfs.tar.bz2 ? ,as for .dtb & other we are putting address .

thanks for quick response.

Regards 

Ankit

0 Kudos

140 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Ankit

actually mfg tools firmware is linux with root file system in ram

fsl-image-mfgtool-initramfs-imx_mfgtools.cpio.gz.u-boot

Build steps are described in attached Yocto Guide sect.6.2 Manufacturing Tool, MFGTool

Best regards
igor

0 Kudos

140 Views
ankitkumarsingh
Contributor II

Hi Igor,

thanks i  tried exercise of  yocto pdf section 6.2.

in the log it is still hanging at the

"UTP: Waiting for device to appear
UTP: file/device node /dev/utp already exists
cpu_id is 0" 

linux-kernel  is not booting completely.

any solution for this. 

0 Kudos

140 Views
ankitkumarsingh
Contributor II

i am attaching the log of usb boot  it hangs at "UTP: file/device node /dev/utp already exists   cpu_id is 0"

file you mention contains the setting of boot_mfg here are the code.

define CONFIG_MFG_ENV_SETTINGS \
"mfgtool_args=setenv bootargs console=${console},${baudrate} " \
CONFIG_BOOTARGS_CMA_SIZE \
"rdinit=/linuxrc " \
"g_mass_storage.stall=0 g_mass_storage.removable=1 " \
"g_mass_storage.file=/fat g_mass_storage.ro=1 " \
"g_mass_storage.idVendor=0x066F g_mass_storage.idProduct=0x37FF "\
"g_mass_storage.iSerialNumber=\"\" "\
CONFIG_MFG_NAND_PARTITION \
"clk_ignore_unused "\
"\0" \
"initrd_addr=0x83800000\0" \
"initrd_high=0xffffffff\0" \
"bootcmd_mfg=run mfgtool_args;bootz ${loadaddr} ${initrd_addr} ${fdt_addr};\0" \

0 Kudos