TrustZone for application security

cancel
Showing results for 
Search instead for 
Did you mean: 

TrustZone for application security

337 Views
jith
Contributor II

Hi, 

As part of our current project, we would like  to support the TrustZone for application security.

We are using iMX8QXP/L4.14.98 GA for our application purpose.

I have gone through the documentation and came to know that, TrustZone support is available for iMX8QXP/L4.14.98 GA but also found that OP-TEE is not available for the iMX8QXP.

Hence, I would like to know how to validate the TrustZone for application security on iMX8QXP?

Is there any application or sources present for testing the TrustZone for application security?

0 Kudos
3 Replies

210 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

 

  OP-TEE support for i.MX8QM and i.MX8QXP is available on the 4.14.78-1.0.0 GA OP-TEE

related source code. But OP-TEE is not enabled by default in Yocto for these SoC's.

 For more details how to enable the OP-TEE support for i.MX 8QM and i.MX 8QXP and the  building method

NDA is required. Let me know if You need it.

Have a great day,

Yuri

 

 

-------------------------------------------------------------------------------

Note:

- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored

 

Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos

210 Views
jith
Contributor II

Hi Yuri,

Thank you for the response.

I will come back on the NDA.

Before proceeding with NDA, I would like to confirm below 2 points.

1.Currently we are planning to use L4.14.98-2.0.0 BSP.I feel OP-TEE supports is available in the  L4.14.98-2.0.0.
Could you please confirm?

2.Whether the OP-TEE is mandatory to provide  Application security using TrustZone ?

0 Kudos

210 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

 

1.

   Yes, OP-TEE supports is available in the  L4.14.98-2.0.0.

2.

   At least OP-TEE is supported by NXP Linux BSP and may be recommended.

Regards,

Yuri.

0 Kudos