Signatured OTA Package Updates

cancel
Showing results for 
Search instead for 
Did you mean: 

Signatured OTA Package Updates

3,039 Views
michaelrobbelot
Contributor IV

Everyone,

I was wondering if anyone has tried to carry out signed updates according to the instructions in section 5.2 of the R13.4 Advanced User Guide? Although unsigned updates seem to work fine, I get the following error message when trying to call sign_target_files_apks

  File "./build/tools/releasetools/sign_target_files_apks", line 349, in <module>    main(sys.argv[1:]) 

  File "./build/tools/releasetools/sign_target_files_apks", line 328, in main    misc_info = common.LoadInfoDict(input_zip) 

  File "/home/.../.../build/tools/releasetools/common.py", line 111, in LoadInfoDict   

       raise ValueError("can't find recovery API version in input target-files")

ValueError: can't find recovery API version in input target-files


I am passing the ota zip from the make ... dist target. I am wondering if this is similar to the problem discussed at: Google Groups


I have gone through the process to generate the keys and made sure the directory referencing those keys are passed to the sign_target_files_apks call.


Michael Robbeloth

Labels (2)
0 Kudos
4 Replies

170 Views
lily_zhang
NXP Employee
NXP Employee

Hello, Michael:

I made one experiment by following the suggestions of guideline and it can work. For example:

1. Created  and switch to the folder vendor/fsl/security/sabresd_6dq/

2. Created keys and key in the passwords:

3. In android root folder, run the command and key in passwords:

~/android/build/tools/releasetools/sign_target_files_apks -d vendor/fsl/security/sabresd_6dq/ out/dist/sabresd_6dq-target_files.zip signed-target_files.zip

4. The command can run well.

170 Views
michaelrobbelot
Contributor IV

Xiaoli,

This is the procedure I followed and it matches up with section 5.2 of the R13.4 Advanced User Guide. However, this does not correct the particular problem I am facing. If it makes a difference, my organization is using Ubuntu 10.04 LTS release on this system.

Michael Robbeloth

0 Kudos

170 Views
YixingKong
Senior Contributor IV

Michael, if your issues had been resolved, please click Correct Answer so that we can close the DI.

Thanks,

Yixing

0 Kudos

170 Views
lily_zhang
NXP Employee
NXP Employee

I didn’t observe this issue. My ubuntu version is 11.04. Suggest you clean the environment and rebuild images.

Best Regards

Lily Zhang

Freescale MPU Support

0 Kudos