Required le2a71chi2c and lA71CH_i2c libraries to compile ibm-watson-iot source for IMX6ULL

cancel
Showing results for 
Search instead for 
Did you mean: 

Required le2a71chi2c and lA71CH_i2c libraries to compile ibm-watson-iot source for IMX6ULL

146 Views
kuldip_kanzariy
Contributor I

https://developer.ibm.com/recipes/tutorials/secure-onboarding-of-nxp-iot-chiptocloud-security/

Source code : https://github.com/ibm-watson-iot/iot-nxpimxa71ch-c

LDFLAGS = -le2a71chi2c -lA71CH_i2c 

/usr/bin/ld: cannot find -le2a71chi2c
/usr/bin/ld: cannot find -lA71CH_i2c

from where to get this dependance libraries ?

Labels (3)
0 Kudos
1 Reply

125 Views
Kan_Li
NXP TechSupport
NXP TechSupport

Hello @kuldip_kanzariy ,

 

You have to build the A71CH OpenSSL engine at first to have these libs if you don't use the the SD card image pre-configured and installed with the A71CH hostlib. Please kindly refer to the A71CH host library documentation "doc/a71chDoxy/html/page_imx6ul_setup_openssl_engine.html" for more details.

 

Hope that helps,

 

Have a great day,
Kan


-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!
- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos