Pulseaudio + Yocto + Systemd

cancel
Showing results for 
Search instead for 
Did you mean: 

Pulseaudio + Yocto + Systemd

Jump to solution
4,983 Views
caiopereira
Contributor III

Hello,

I'm trying to add the pulseadio into my Image

So I added these lines in my local.conf

DISTRO_FEATURES_append = " pulseaudio opengl wifi ethernet loopback udev dbus systemd"

IMAGE_INSTALL_append = " qtbase qtbase-fonts qtbase-plugins qtmultimedia qtmultimedia-plugins qtmultimedia-qmlplugins qtbase-examples cinematicexperience tslib tslib-calibrate tslib-conf tslib-tests sisc imx-vpu  gpu-viv-bin-mx6q sqlite3  packagegroup-fslc-gstreamer1.0 dbus pulseaudio pulseaudio-server pulseaudio-misc pulseaudio-module-dbus-protocol alsa-utils i2c-tools"

PACKAGECONFIG_append_pn-pulseaudio = " systemd"

But when the Linux boot the pulseaudio doesn't start, there's no pulseadio.service.

When I try to run the pulseaudio with --system or -nC ,I get some error in the console. Which is the best way to starts pulseaudio with dbus and systemd?

Someone could help me?

Yocto 1.7.

Thank you very much.

Best Regards

Caio Pereira

Labels (4)
0 Kudos
1 Solution
837 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Caio

dbus systemd is not supported in nxp/fsl linux bsps, as for pulseaudio

configuration with linux one can look at attached linux guide

sect.7.4 Pulseaudio input/output settings.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

2 Replies
837 Views
caiopereira
Contributor III

After add the root into pulse group I could use the pulseaudio

gpasswd -a root audio

pulseaudio --system

I test the pulse audio using the gstreamer.

gst-launch-0.10 filesrc location=/usr/share/sounds/alsa/Front_Right.wav ! wavparse ! pulsesink

But the audio it's crackling, it's horrible.

I tryed with pulseaudio --system --realtime, but I couldn't resolve the latency problem.

Someone could give an advice to configure the pulseaudio?

Thank you!

0 Kudos
838 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Caio

dbus systemd is not supported in nxp/fsl linux bsps, as for pulseaudio

configuration with linux one can look at attached linux guide

sect.7.4 Pulseaudio input/output settings.

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post